# CVE-2024-21542: luigi Arbitrary File Write via Archive Extraction (Zip Slip)

> Attackers can write arbitrary files via Zip Slip in Luigi, potentially leading to code execution or data modification.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:H/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Dec 2024
- **Updated:** 3 Aug 2026
- **Also known as:** GHSA-8qch-vj6m-2694, PYSEC-2024-159

## What is CVE-2024-21542?

CVE-2024-21542 is a high-severity path traversal vulnerability in luigi, published on 10 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package luigi before 3.6.0 are vulnerable to Arbitrary File Write via Archive Extraction (Zip Slip) due to improper destination file path validation in the _extract_packages_archive function.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-29 (Path Traversal: '\..\filename')

## Which versions are affected by CVE-2024-21542?

3 open source packages ship an affected version, including luigi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `luigi` | PyPI | All versions | 3.6.0 |
| `luigi` | PyPI | All versions | 3.6.0 |
| `luigi` | PyPI | All versions | 3.6.0 |

## How do I fix CVE-2024-21542?

Upgrade luigi to 3.6.0 or later.

## Is CVE-2024-21542 being exploited?

There is no known exploitation of CVE-2024-21542 in the wild and no public exploit code.

Public exploit code:

- https://github.com/L3ster1337/Poc-CVE-2024-21542 (github_poc): https://github.com/L3ster1337/Poc-CVE-2024-21542

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21542 and fix it if it is affected.

What it is: CVE-2024-21542 is a high-severity path traversal vulnerability in luigi, published on 10 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-21542 in the wild and no public exploit code.

Affected packages and fixed versions:
- luigi (PyPI): affected all versions; fixed in 3.6.0
- luigi (PyPI): affected all versions; fixed in 3.6.0
- luigi (PyPI): affected all versions; fixed in 3.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21542/ (Markdown: https://insights.sbomify.com/CVE-2024-21542/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21542
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21542
- OSV: https://osv.dev/vulnerability/CVE-2024-21542

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21542/
Summaries are generated and may contain mistakes; the official description above is the record.
