# CVE-2024-21543: djoser Authentication Bypass

> Attackers can bypass two-factor authentication and other custom checks by exploiting a fallback to direct database queries in the djoser library.

- **Severity:** Medium 5.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Dec 2024
- **Updated:** 20 Feb 2025
- **Also known as:** DEBIAN-CVE-2024-21543, DLA-4060-1, GHSA-v49p-m6gh-747c, PYSEC-2024-158, UBUNTU-CVE-2024-21543, USN-7354-1

## What is CVE-2024-21543?

CVE-2024-21543 is a medium-severity authentication bypass vulnerability in djoser, published on 13 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Versions of the package djoser before 2.3.0 are vulnerable to Authentication Bypass when the authenticate() function fails. This is because the system falls back to querying the database directly, granting access to users with valid credentials, and eventually bypassing custom authentication checks such as two-factor authentication, LDAP validations, or requirements from configured AUTHENTICATION_BACKENDS.

Weakness: CWE-295 (Improper Certificate Validation), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-21543?

3 open source packages ship an affected version, including djoser.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `djoser` | PyPI | All versions | 2.3.0 |
| `djoser` | PyPI | All versions | 2.3.0 |
| `djoser` | PyPI | All versions | 2.3.0 |

## How do I fix CVE-2024-21543?

Upgrade djoser to 2.3.0 or later.

## Is CVE-2024-21543 being exploited?

There is no known exploitation of CVE-2024-21543 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21543 and fix it if it is affected.

What it is: CVE-2024-21543 is a medium-severity authentication bypass vulnerability in djoser, published on 13 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-21543 in the wild and no public exploit code.

Affected packages and fixed versions:
- djoser (PyPI): affected all versions; fixed in 2.3.0
- djoser (PyPI): affected all versions; fixed in 2.3.0
- djoser (PyPI): affected all versions; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21543/ (Markdown: https://insights.sbomify.com/CVE-2024-21543/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21543
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21543
- OSV: https://osv.dev/vulnerability/CVE-2024-21543

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21543/
Summaries are generated and may contain mistakes; the official description above is the record.
