# CVE-2024-21544: Browsershot Local File Inclusion

> An attacker can read sensitive server files by exploiting improper URL validation in the setUrl method of the browsershot library.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Dec 2024
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-g2r4-phv7-5fgv

## What is CVE-2024-21544?

CVE-2024-21544 is a high-severity path traversal vulnerability in spatie/browsershot, published on 13 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package spatie/browsershot before 5.0.1 are vulnerable to Improper Input Validation due to improper URL validation in the setUrl method.An attacker can exploit this vulnerability by using leading whitespace (%20) before the file:// protocol, resulting in Local File Inclusion, which allows the attacker to read sensitive files on the server.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-21544?

2 open source packages ship an affected version, including spatie/browsershot.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `spatie/browsershot` | Packagist | All versions | 5.0.1 |
| `spatie/browsershot` | Packagist | All versions | 5.0.1 |

## How do I fix CVE-2024-21544?

Upgrade spatie/browsershot to 5.0.1 or later.

## Is CVE-2024-21544 being exploited?

There is no known exploitation of CVE-2024-21544 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21544 and fix it if it is affected.

What it is: CVE-2024-21544 is a high-severity path traversal vulnerability in spatie/browsershot, published on 13 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-21544 in the wild and no public exploit code.

Affected packages and fixed versions:
- spatie/browsershot (Packagist): affected all versions; fixed in 5.0.1
- spatie/browsershot (Packagist): affected all versions; fixed in 5.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21544/ (Markdown: https://insights.sbomify.com/CVE-2024-21544/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21544
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21544
- OSV: https://osv.dev/vulnerability/CVE-2024-21544

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21544/
Summaries are generated and may contain mistakes; the official description above is the record.
