CVE-2024-21548 Other in bun

High 7.7 Published Updated

Prototype pollution in Bun runtime allows attackers to manipulate object prototypes via APIs, potentially leading to code execution or privilege escalation.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-21548?

CVE-2024-21548 is a high-severity vulnerability in bun, published on 18 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Versions of the package bun after 0.0.12 and before 1.1.30 are vulnerable to Prototype Pollution due to improper input sanitization. An attacker can exploit this vulnerability through Bun's APIs that accept objects. **Note:** This issue relates to the widely known and actively developed 'Bun' JavaScript runtime. The bun package on NPM at versions 0.0.12 and below belongs to a different and older project that happened to claim the 'bun' name in the past.

Weakness: CWE-1321

Which versions are affected by CVE-2024-21548?

1 open source package ship an affected version, including bun.

PackageAffectedFixed in
bun npmAll versions1.1.30

How do I fix CVE-2024-21548?

Upgrade bun to 1.1.30 or later.

Is CVE-2024-21548 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21548 exists.

Sources

Also known as GHSA-v9mx-4pqq-h232.

Is CVE-2024-21548 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free