CVE-2024-21622 Craft CMS Privilege Escalation
Attackers with specific user permissions can escalate privileges in Craft CMS, requiring an upgrade to secure the system.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-21622?
CVE-2024-21622 is a medium-severity vulnerability in Craftcms Craft Cms, published on 3 Jan 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Craft is a content management system. This is a potential moderate impact, low complexity privilege escalation vulnerability in Craft starting in 3.x prior to 3.9.6 and 4.x prior to 4.4.16 with certain user permissions setups. This has been fixed in Craft 4.4.16 and Craft 3.9.6. Users should ensure they are running at least those versions.
Weakness: CWE-269
Which versions are affected by CVE-2024-21622?
4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 3.0.0 | 3.9.6 |
craftcms/cms Packagist | From 3.0.0 | 3.9.6 |
craftcms/cms Packagist | From 4.0.0-RC1 | 4.5.11 |
craftcms/cms Packagist | From 4.0.0-RC1 | 4.5.11 |
Products include Craftcms Craft Cms.
How do I fix CVE-2024-21622?
Upgrade craftcms/cms to a fixed version for your release line: 3.9.6 or 4.5.11.
Is CVE-2024-21622 being exploited?
There is no known exploitation of CVE-2024-21622 in the wild and no public exploit code.
Other vulnerabilities in Craftcms Craft Cms
Sources
Also known as GHSA-j5g9-j7r4-6qvx.