{"answers":{"affected":"4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-21622 in the wild and no public exploit code.","fix":"Upgrade craftcms/cms to a fixed version for your release line: 3.9.6 or 4.5.11.","what":"CVE-2024-21622 is a medium-severity vulnerability in Craftcms Craft Cms, published on 3 Jan 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-21622 and fix it if it is affected.\n\nWhat it is: CVE-2024-21622 is a medium-severity vulnerability in Craftcms Craft Cms, published on 3 Jan 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-21622 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- craftcms/cms (Packagist): affected from 3.0.0; fixed in 3.9.6\n- craftcms/cms (Packagist): affected from 3.0.0; fixed in 3.9.6\n- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.5.11\n- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.5.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-21622/ (Markdown: https://insights.sbomify.com/CVE-2024-21622/index.md)","id":"CVE-2024-21622","markdown":"https://insights.sbomify.com/CVE-2024-21622/index.md","name":"CVE-2024-21622","record":{"aliases":["GHSA-j5g9-j7r4-6qvx"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Craft CMS","requires_auth":"low_privilege","summary":"Attackers with specific user permissions can escalate privileges in Craft CMS, requiring an upgrade to secure the system.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"craft_cms","vendor":"craftcms"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Craft is a content management system. This is a potential moderate impact, low complexity privilege escalation vulnerability in Craft starting in 3.x prior to 3.9.6 and 4.x prior to 4.4.16 with certain user permissions setups. This has been fixed in Craft 4.4.16 and Craft 3.9.6. Users should ensure they are running at least those versions.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Craft CMS Privilege Escalation","id":"CVE-2024-21622","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"craftcms:craft_cms","products":["craftcms:craft_cms"],"type":"privilege_escalation","year":"2024"},"n_packages":4,"n_references":7,"next":{"headline":"Arbitrary Expression Injection in github workflow leads to Command execution \u0026 leaking secrets","id":"CVE-2024-21623"},"packages":[{"ecosystem":"Packagist","fixed":["3.9.6"],"introduced":["3.0.0"],"last_affected":[],"package":"craftcms/cms","purl":null,"source":"GHSA-j5g9-j7r4-6qvx"},{"ecosystem":"Packagist","fixed":["3.9.6"],"introduced":["3.0.0"],"last_affected":[],"package":"craftcms/cms","purl":"pkg:composer/craftcms/cms","source":"GHSA-j5g9-j7r4-6qvx"},{"ecosystem":"Packagist","fixed":["4.5.11"],"introduced":["4.0.0-RC1"],"last_affected":[],"package":"craftcms/cms","purl":null,"source":"GHSA-j5g9-j7r4-6qvx"},{"ecosystem":"Packagist","fixed":["4.5.11"],"introduced":["4.0.0-RC1"],"last_affected":[],"package":"craftcms/cms","purl":"pkg:composer/craftcms/cms","source":"GHSA-j5g9-j7r4-6qvx"}],"prev":{"headline":"Junos OS: SRX Series and EX Series: J-Web doesn't sufficiently sanitize input to prevent XSS","id":"CVE-2024-21620"},"products":["cms"],"published":"2024-01-03","related":[{"cvss_score":10,"headline":"Craft CMS Code Injection","id":"CVE-2025-32432","kev_date_added":"2026-03-20","published":"2025-04-25"},{"cvss_score":9.3,"headline":"Craft CMS Code Injection","id":"CVE-2024-56145","kev_date_added":"2025-06-02","published":"2024-12-18"},{"cvss_score":8.1,"headline":"Craft CMS Code Injection","id":"CVE-2025-23209","kev_date_added":"2025-02-20","published":"2025-01-18"},{"cvss_score":6.9,"headline":"Craft CMS External Control of Assumed-Immutable Web Parameter","id":"CVE-2025-35939","kev_date_added":"2025-06-02","published":"2025-05-07"},{"cvss_score":10,"headline":"Craft CMS Remote Code Execution vulnerability","id":"CVE-2023-41892","kev_date_added":null,"published":"2023-09-13"},{"cvss_score":9.8,"headline":"Craft CMS Remote Code Injection","id":"CVE-2021-27903","kev_date_added":null,"published":"2021-06-30"},{"cvss_score":9.8,"headline":"SEOmatic for CraftCMS allows Server-Side Template Injection","id":"CVE-2020-9757","kev_date_added":null,"published":"2020-03-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-17","vendors":["craftcms"]},"summary":"Attackers with specific user permissions can escalate privileges in Craft CMS, requiring an upgrade to secure the system.","url":"https://insights.sbomify.com/CVE-2024-21622/"}