# CVE-2024-21622: Craft CMS Privilege Escalation

> Attackers with specific user permissions can escalate privileges in Craft CMS, requiring an upgrade to secure the system.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jan 2024
- **Updated:** 17 Apr 2025
- **Also known as:** GHSA-j5g9-j7r4-6qvx

## What is CVE-2024-21622?

CVE-2024-21622 is a medium-severity vulnerability in Craftcms Craft Cms, published on 3 Jan 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Craft is a content management system. This is a potential moderate impact, low complexity privilege escalation vulnerability in Craft starting in 3.x prior to 3.9.6 and 4.x prior to 4.4.16 with certain user permissions setups. This has been fixed in Craft 4.4.16 and Craft 3.9.6. Users should ensure they are running at least those versions.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2024-21622?

4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 3.0.0 | 3.9.6 |
| `craftcms/cms` | Packagist | From 3.0.0 | 3.9.6 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.5.11 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.5.11 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2024-21622?

Upgrade craftcms/cms to a fixed version for your release line: 3.9.6 or 4.5.11.

## Is CVE-2024-21622 being exploited?

There is no known exploitation of CVE-2024-21622 in the wild and no public exploit code.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21622 and fix it if it is affected.

What it is: CVE-2024-21622 is a medium-severity vulnerability in Craftcms Craft Cms, published on 3 Jan 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-21622 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 3.0.0; fixed in 3.9.6
- craftcms/cms (Packagist): affected from 3.0.0; fixed in 3.9.6
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.5.11
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.5.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21622/ (Markdown: https://insights.sbomify.com/CVE-2024-21622/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21622
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21622
- OSV: https://osv.dev/vulnerability/CVE-2024-21622

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21622/
Summaries are generated and may contain mistakes; the official description above is the record.
