# CVE-2024-21624: Potential Information Leak in User-Constructed Message Templates in nonebot2

> Attackers can leak sensitive data like environment variables if developers improperly use user input in message templates.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Feb 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-59j8-776v-xxxg, PYSEC-2024-37

## What is CVE-2024-21624?

CVE-2024-21624 is a medium-severity vulnerability in nonebot2, published on 9 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

nonebot2 is a cross-platform Python asynchronous chatbot framework written in Python. This security advisory pertains to a potential information leak (e.g., environment variables) in instances where developers utilize `MessageTemplate` and incorporate user-provided data into templates. The identified vulnerability has been remedied in pull request #2509 and will be included in versions released from 2.2.0. Users are strongly advised to upgrade to these patched versions to safeguard against the vulnerability. A temporary workaround involves filtering underscores before incorporating user input into the message template.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-21624?

3 open source packages ship an affected version, including nonebot2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nonebot2` | PyPI | From 2.0.0a16 | 2.2.0 |
| `nonebot2` | PyPI | From 2.0.0a16 | 2.2.0 |
| `nonebot2` | PyPI | From 2.0.1 | 2.2.0 |

Products: Nonebot Nonebot.

## How do I fix CVE-2024-21624?

Upgrade nonebot2 to 2.2.0 or later.

## Is CVE-2024-21624 being exploited?

There is no known exploitation of CVE-2024-21624 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21624 and fix it if it is affected.

What it is: CVE-2024-21624 is a medium-severity vulnerability in nonebot2, published on 9 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-21624 in the wild and no public exploit code.

Affected packages and fixed versions:
- nonebot2 (PyPI): affected from 2.0.0a16; fixed in 2.2.0
- nonebot2 (PyPI): affected from 2.0.0a16; fixed in 2.2.0
- nonebot2 (PyPI): affected from 2.0.1; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21624/ (Markdown: https://insights.sbomify.com/CVE-2024-21624/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21624
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21624
- OSV: https://osv.dev/vulnerability/CVE-2024-21624

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21624/
Summaries are generated and may contain mistakes; the official description above is the record.
