{"answers":{"affected":"4 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-21627 in the wild and no public exploit code.","fix":"Upgrade prestashop/prestashop to a fixed version for your release line: 1.7.8.11 or 8.1.3.","what":"CVE-2024-21627 is a high-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 2 Jan 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-21627 and fix it if it is affected.\n\nWhat it is: CVE-2024-21627 is a high-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 2 Jan 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-21627 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- prestashop/prestashop (Packagist): affected all versions; fixed in 1.7.8.11\n- prestashop/prestashop (Packagist): affected all versions; fixed in 1.7.8.11\n- prestashop/prestashop (Packagist): affected from 8.0.0-beta.1; fixed in 8.1.3\n- prestashop/prestashop (Packagist): affected from 8.0.0-beta.1; fixed in 8.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-21627/ (Markdown: https://insights.sbomify.com/CVE-2024-21627/index.md)","id":"CVE-2024-21627","markdown":"https://insights.sbomify.com/CVE-2024-21627/index.md","name":"CVE-2024-21627","record":{"aliases":["GHSA-xgpm-q3mq-46rq"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"PrestaShop e-commerce platform","requires_auth":"high_privilege","summary":"Attackers can inject malicious scripts via unescaped HTML attributes in PrestaShop, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"prestashop","vendor":"prestashop"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"PrestaShop is an open-source e-commerce platform. Prior to versions 8.1.3 and 1.7.8.11, some event attributes are not detected by the `isCleanHTML` method. Some modules using the `isCleanHTML` method could be vulnerable to cross-site scripting. Versions 8.1.3 and 1.7.8.11 contain a patch for this issue. The best workaround is to use the `HTMLPurifier` library to sanitize html input coming from users. The library is already available as a dependency in the PrestaShop project. Beware though that in legacy object models, fields of `HTML` type will call `isCleanHTML`.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Some attribute not escaped in Validate::isCleanHTML method","id":"CVE-2024-21627","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"prestashop:prestashop","products":["prestashop:prestashop"],"type":"xss","year":"2024"},"n_packages":4,"n_references":3,"next":{"headline":"XSS can be stored in DB from \"add a message form\" in order detail page (FO)","id":"CVE-2024-21628"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.8.11"],"introduced":["0"],"last_affected":[],"package":"prestashop/prestashop","purl":null,"source":"GHSA-xgpm-q3mq-46rq"},{"ecosystem":"Packagist","fixed":["1.7.8.11"],"introduced":["0"],"last_affected":[],"package":"prestashop/prestashop","purl":"pkg:composer/prestashop/prestashop","source":"GHSA-xgpm-q3mq-46rq"},{"ecosystem":"Packagist","fixed":["8.1.3"],"introduced":["8.0.0-beta.1"],"last_affected":[],"package":"prestashop/prestashop","purl":null,"source":"GHSA-xgpm-q3mq-46rq"},{"ecosystem":"Packagist","fixed":["8.1.3"],"introduced":["8.0.0-beta.1"],"last_affected":[],"package":"prestashop/prestashop","purl":"pkg:composer/prestashop/prestashop","source":"GHSA-xgpm-q3mq-46rq"}],"prev":{"headline":"runc container breakout through process.cwd trickery and leaked fds","id":"CVE-2024-21626"},"products":["PrestaShop"],"published":"2024-01-02","related":[{"cvss_score":10,"headline":"PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using \"SQL Manager\"","id":"CVE-2023-30839","kev_date_added":null,"published":"2023-04-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2008-5791","kev_date_added":null,"published":"2008-12-31"},{"cvss_score":9.8,"headline":"Server-side request forgery in n/a","id":"CVE-2024-41651","kev_date_added":null,"published":"2024-08-12"},{"cvss_score":9.8,"headline":"Remote code execution in prestashop","id":"CVE-2022-31181","kev_date_added":null,"published":"2022-08-01"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2021-3110","kev_date_added":null,"published":"2021-01-20"},{"cvss_score":9.8,"headline":"Blind SQL Injection in PrestaShop","id":"CVE-2020-15160","kev_date_added":null,"published":"2020-09-24"},{"cvss_score":9.8,"headline":"Privilege escalation in n/a","id":"CVE-2013-6295","kev_date_added":null,"published":"2020-02-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-06-03","vendors":["PrestaShop"]},"summary":"Attackers can inject malicious scripts via unescaped HTML attributes in PrestaShop, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2024-21627/"}