# CVE-2024-21627: Some attribute not escaped in Validate::isCleanHTML method

> Attackers can inject malicious scripts via unescaped HTML attributes in PrestaShop, potentially leading to session hijacking or code execution.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jan 2024
- **Updated:** 3 Jun 2025
- **Also known as:** GHSA-xgpm-q3mq-46rq

## What is CVE-2024-21627?

CVE-2024-21627 is a high-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 2 Jan 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

PrestaShop is an open-source e-commerce platform. Prior to versions 8.1.3 and 1.7.8.11, some event attributes are not detected by the `isCleanHTML` method. Some modules using the `isCleanHTML` method could be vulnerable to cross-site scripting. Versions 8.1.3 and 1.7.8.11 contain a patch for this issue. The best workaround is to use the `HTMLPurifier` library to sanitize html input coming from users. The library is already available as a dependency in the PrestaShop project. Beware though that in legacy object models, fields of `HTML` type will call `isCleanHTML`.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-21627?

4 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/prestashop` | Packagist | All versions | 1.7.8.11 |
| `prestashop/prestashop` | Packagist | All versions | 1.7.8.11 |
| `prestashop/prestashop` | Packagist | From 8.0.0-beta.1 | 8.1.3 |
| `prestashop/prestashop` | Packagist | From 8.0.0-beta.1 | 8.1.3 |

Products: Prestashop Prestashop.

## How do I fix CVE-2024-21627?

Upgrade prestashop/prestashop to a fixed version for your release line: 1.7.8.11 or 8.1.3.

## Is CVE-2024-21627 being exploited?

There is no known exploitation of CVE-2024-21627 in the wild and no public exploit code.

## Other vulnerabilities in Prestashop Prestashop

- [CVE-2023-30839](https://insights.sbomify.com/CVE-2023-30839/): PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager" (critical 10.0)
- [CVE-2008-5791](https://insights.sbomify.com/CVE-2008-5791/): Other in n/a (critical 10.0)
- [CVE-2024-41651](https://insights.sbomify.com/CVE-2024-41651/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-31181](https://insights.sbomify.com/CVE-2022-31181/): Remote code execution in prestashop (critical 9.8)
- [CVE-2021-3110](https://insights.sbomify.com/CVE-2021-3110/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21627 and fix it if it is affected.

What it is: CVE-2024-21627 is a high-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 2 Jan 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-21627 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/prestashop (Packagist): affected all versions; fixed in 1.7.8.11
- prestashop/prestashop (Packagist): affected all versions; fixed in 1.7.8.11
- prestashop/prestashop (Packagist): affected from 8.0.0-beta.1; fixed in 8.1.3
- prestashop/prestashop (Packagist): affected from 8.0.0-beta.1; fixed in 8.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21627/ (Markdown: https://insights.sbomify.com/CVE-2024-21627/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21627
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21627
- OSV: https://osv.dev/vulnerability/CVE-2024-21627

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21627/
Summaries are generated and may contain mistakes; the official description above is the record.
