# CVE-2024-21628: XSS can be stored in DB from "add a message form" in order detail page (FO)

> Attackers can store XSS payloads in the database via the order detail message form, affecting customers viewing the page in the frontend.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jan 2024
- **Updated:** 14 Nov 2024
- **Also known as:** GHSA-vr7m-r9vm-m4wf

## What is CVE-2024-21628?

CVE-2024-21628 is a medium-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 2 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

PrestaShop is an open-source e-commerce platform. Prior to version 8.1.3, the isCleanHtml method is not used on this this form, which makes it possible to store a cross-site scripting payload in the database. The impact is low because the HTML is not interpreted in BO, thanks to twig's escape mechanism. In FO, the cross-site scripting attack is effective, but only impacts the customer sending it, or the customer session from which it was sent. This issue affects those who have a module fetching these messages from the DB and displaying it without escaping HTML. Version 8.1.3 contains a patch for this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-21628?

2 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/prestashop` | Packagist | All versions | 8.1.3 |
| `prestashop/prestashop` | Packagist | All versions | 8.1.3 |

Products: Prestashop Prestashop.

## How do I fix CVE-2024-21628?

Upgrade prestashop/prestashop to 8.1.3 or later.

## Is CVE-2024-21628 being exploited?

There is no known exploitation of CVE-2024-21628 in the wild and no public exploit code.

## Other vulnerabilities in Prestashop Prestashop

- [CVE-2023-30839](https://insights.sbomify.com/CVE-2023-30839/): PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager" (critical 10.0)
- [CVE-2008-5791](https://insights.sbomify.com/CVE-2008-5791/): Other in n/a (critical 10.0)
- [CVE-2024-41651](https://insights.sbomify.com/CVE-2024-41651/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-31181](https://insights.sbomify.com/CVE-2022-31181/): Remote code execution in prestashop (critical 9.8)
- [CVE-2021-3110](https://insights.sbomify.com/CVE-2021-3110/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21628 and fix it if it is affected.

What it is: CVE-2024-21628 is a medium-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 2 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-21628 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/prestashop (Packagist): affected all versions; fixed in 8.1.3
- prestashop/prestashop (Packagist): affected all versions; fixed in 8.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21628/ (Markdown: https://insights.sbomify.com/CVE-2024-21628/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21628
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21628
- OSV: https://osv.dev/vulnerability/CVE-2024-21628

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21628/
Summaries are generated and may contain mistakes; the official description above is the record.
