# CVE-2024-21632: omniauth-microsoft_graph vulnerable to account takeover (nOAuth)

> Attackers can take over accounts if the email attribute is trusted without validation, requiring a fix in the omniauth-microsoft_graph library.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-5g66-628f-7cvj

## What is CVE-2024-21632?

CVE-2024-21632 is a high-severity authentication bypass vulnerability in synth omniauth-microsoft_graph, published on 2 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

omniauth-microsoft_graph provides an Omniauth strategy for the Microsoft Graph API. Prior to versions 2.0.0, the implementation did not validate the legitimacy of the `email` attribute of the user nor did it give/document an option to do so, making it susceptible to nOAuth misconfiguration in cases when the `email` is used as a trusted user identifier. This could lead to account takeover. Version 2.0.0 contains a fix for this issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-21632?

2 open source packages ship an affected version, including omniauth-microsoft_graph. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `omniauth-microsoft_graph` | RubyGems | All versions | 2.0.0 |
| `omniauth-microsoft_graph` | RubyGems | All versions | 2.0.0 |

Products: Recognizeapp Omniauth\.

## How do I fix CVE-2024-21632?

Upgrade omniauth-microsoft_graph to 2.0.0 or later.

## Is CVE-2024-21632 being exploited?

There is no known exploitation of CVE-2024-21632 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21632 and fix it if it is affected.

What it is: CVE-2024-21632 is a high-severity authentication bypass vulnerability in synth omniauth-microsoft_graph, published on 2 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-21632 in the wild and no public exploit code.

Affected packages and fixed versions:
- omniauth-microsoft_graph (RubyGems): affected all versions; fixed in 2.0.0
- omniauth-microsoft_graph (RubyGems): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21632/ (Markdown: https://insights.sbomify.com/CVE-2024-21632/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21632
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21632
- OSV: https://osv.dev/vulnerability/CVE-2024-21632

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21632/
Summaries are generated and may contain mistakes; the official description above is the record.
