# CVE-2024-21635: Memos Access Tokens Stay Valid after User Password Change

> Attackers retain account access via valid tokens after password changes, requiring manual token deletion to secure compromised accounts.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Nov 2025
- **Updated:** 14 Nov 2025
- **Also known as:** GHSA-mr34-8733-grr2, GO-2025-4127

## What is CVE-2024-21635?

CVE-2024-21635 is a high-severity authentication bypass vulnerability in Usememos Memos, published on 14 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Memos is a privacy-first, lightweight note-taking service that uses Access Tokens to authenticate application access. When a user changes their password, the existing list of Access Tokens stay valid instead of expiring. If a user finds that their account has been compromised, they can update their password. In versions up to and including 0.18.1, though, the bad actor will still have access to their account because the bad actor's Access Token stays on the list as a valid token. The user will have to manually delete the bad actor's Access Token to secure their account. The list of Access Tokens has a generic Description which makes it hard to pinpoint a bad actor in a list of Access Tokens. A known patched version of Memos isn't available. To improve Memos security, all Access Tokens will need to be revoked when a user changes their password. This removes the session for all the user's devices and prompts the user to log in again. One can treat the old Access Tokens as "invalid" because those Access Tokens were created with the older password.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-21635?

3 open source packages ship an affected version, including github.com/usememos/memos. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/usememos/memos` | Go | All versions | None |
| `github.com/usememos/memos` | Go | All versions | 0.18.2 |
| `github.com/usememos/memos` | Go | All versions | 0.18.2 |

Products: Usememos Memos.

## How do I fix CVE-2024-21635?

Upgrade github.com/usememos/memos to 0.18.2 or later.

## Is CVE-2024-21635 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21635 exists.

## Other vulnerabilities in Usememos Memos

- [CVE-2025-50738](https://insights.sbomify.com/CVE-2025-50738/): Memos has Cross-Site Scripting (XSS) Vulnerability in Image URLs (critical 9.8)
- [CVE-2025-22952](https://insights.sbomify.com/CVE-2025-22952/): Memos Server-Side Request Forgery (SSRF) (critical 9.8)
- [CVE-2023-0109](https://insights.sbomify.com/CVE-2023-0109/): Stored XSS in usememos/memos (critical 9.8)
- [CVE-2023-4696](https://insights.sbomify.com/CVE-2023-4696/): Improper Access Control in usememos/memos (critical 9.8)
- [CVE-2022-4866](https://insights.sbomify.com/CVE-2022-4866/): Cross-site Scripting (XSS) - Stored in usememos/memos (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21635 and fix it if it is affected.

What it is: CVE-2024-21635 is a high-severity authentication bypass vulnerability in Usememos Memos, published on 14 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21635 exists.

Affected packages and fixed versions:
- github.com/usememos/memos (Go): affected all versions; no fix listed
- github.com/usememos/memos (Go): affected all versions; fixed in 0.18.2
- github.com/usememos/memos (Go): affected all versions; fixed in 0.18.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21635/ (Markdown: https://insights.sbomify.com/CVE-2024-21635/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21635
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21635
- OSV: https://osv.dev/vulnerability/CVE-2024-21635

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21635/
Summaries are generated and may contain mistakes; the official description above is the record.
