CVE-2024-21636 view_component Cross-site Scripting vulnerability
Attackers can inject malicious scripts via unsanitized component output in view_component, affecting applications rendering components directly from controllers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-21636?
CVE-2024-21636 is a medium-severity cross-site scripting vulnerability in ViewComponent view_component, published on 4 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
view_component is a framework for building reusable, testable, and encapsulated view components in Ruby on Rails. Versions prior to 3.9.0 and 2.83.0 have a cross-site scripting vulnerability that has the potential to impact anyone rendering a component directly from a controller with the view_component gem. Note that only components that define a `#call` method (i.e. instead of using a sidecar template) are affected. The return value of the `#call` method is not sanitized and can include user-defined content. In addition, the return value of the `#output_postamble` methodis not sanitized, which can also lead to cross-site scripting issues. Versions 3.9.0 and 2.83.0 have been released and fully mitigate both the `#call` and the `#output_postamble` vulnerabilities. As a workaround, sanitize the return value of `#call`.
Weakness: CWE-79
Which versions are affected by CVE-2024-21636?
4 open source packages ship an affected version, including view_component. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
view_component RubyGems | All versions | 2.83.0 |
view_component RubyGems | All versions | 2.83.0 |
view_component RubyGems | From 3.0.0 | 3.9.0 |
view_component RubyGems | From 3.0.0 | 3.9.0 |
Products include Viewcomponent View Component.
How do I fix CVE-2024-21636?
Upgrade view_component to a fixed version for your release line: 2.83.0 or 3.9.0.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-21636 being exploited?
There is no known exploitation of CVE-2024-21636 in the wild and no public exploit code.
Other vulnerabilities in ViewComponent view_component
Sources
Also known as GHSA-wf2x-8w6j-qw37.