# CVE-2024-21636: view_component Cross-site Scripting vulnerability

> Attackers can inject malicious scripts via unsanitized component output in view_component, affecting applications rendering components directly from controllers.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-wf2x-8w6j-qw37

## What is CVE-2024-21636?

CVE-2024-21636 is a medium-severity cross-site scripting vulnerability in ViewComponent view_component, published on 4 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

view_component is a framework for building reusable, testable, and encapsulated view components in Ruby on Rails. Versions prior to 3.9.0 and 2.83.0 have a cross-site scripting vulnerability that has the potential to impact anyone rendering a component directly from a controller with the view_component gem. Note that only components that define a `#call` method (i.e. instead of using a sidecar template) are affected. The return value of the `#call` method is not sanitized and can include user-defined content. In addition, the return value of the `#output_postamble` methodis not sanitized, which can also lead to cross-site scripting issues. Versions 3.9.0 and 2.83.0 have been released and fully mitigate both the `#call` and the `#output_postamble` vulnerabilities. As a workaround, sanitize the return value of `#call`.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-21636?

4 open source packages ship an affected version, including view_component. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `view_component` | RubyGems | All versions | 2.83.0 |
| `view_component` | RubyGems | All versions | 2.83.0 |
| `view_component` | RubyGems | From 3.0.0 | 3.9.0 |
| `view_component` | RubyGems | From 3.0.0 | 3.9.0 |

Products: Viewcomponent View Component.

## How do I fix CVE-2024-21636?

Upgrade view_component to a fixed version for your release line: 2.83.0 or 3.9.0.

## Is CVE-2024-21636 being exploited?

There is no known exploitation of CVE-2024-21636 in the wild and no public exploit code.

## Other vulnerabilities in ViewComponent view_component

- [CVE-2026-54498](https://insights.sbomify.com/CVE-2026-54498/): view_component: around_render HTML-Safety Bypass (high 8.7)
- [CVE-2026-54497](https://insights.sbomify.com/CVE-2026-54497/): view_component: Reused Component Instances Retain Stale Render Context (medium 6.8)
- [CVE-2026-44837](https://insights.sbomify.com/CVE-2026-44837/): view_component: System Test Entry Point Path Check Allows Sibling Directory Escape (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21636 and fix it if it is affected.

What it is: CVE-2024-21636 is a medium-severity cross-site scripting vulnerability in ViewComponent view_component, published on 4 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-21636 in the wild and no public exploit code.

Affected packages and fixed versions:
- view_component (RubyGems): affected all versions; fixed in 2.83.0
- view_component (RubyGems): affected all versions; fixed in 2.83.0
- view_component (RubyGems): affected from 3.0.0; fixed in 3.9.0
- view_component (RubyGems): affected from 3.0.0; fixed in 3.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21636/ (Markdown: https://insights.sbomify.com/CVE-2024-21636/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21636
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21636
- OSV: https://osv.dev/vulnerability/CVE-2024-21636

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21636/
Summaries are generated and may contain mistakes; the official description above is the record.
