{"answers":{"affected":"4 open source packages ship an affected version, including flarum/framework and flarum/core. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21641 exists.","fix":"Upgrade flarum/framework to 1.8.5 or later.","what":"CVE-2024-21641 is a medium-severity vulnerability in flarum framework, published on 5 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-21641 and fix it if it is affected.\n\nWhat it is: CVE-2024-21641 is a medium-severity vulnerability in flarum framework, published on 5 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21641 exists.\n\nAffected packages and fixed versions:\n- flarum/framework (Packagist): affected all versions; fixed in 1.8.5\n- flarum/framework (Packagist): affected all versions; fixed in 1.8.5\n- flarum/core (Packagist): affected all versions; fixed in 1.8.5\n- flarum/core (Packagist): affected all versions; fixed in 1.8.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-21641/ (Markdown: https://insights.sbomify.com/CVE-2024-21641/index.md)","id":"CVE-2024-21641","markdown":"https://insights.sbomify.com/CVE-2024-21641/index.md","name":"CVE-2024-21641","record":{"aliases":["GHSA-733r-8xcp-w9mr"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Flarum discussion platform","requires_auth":"none","summary":"Attackers can redirect users from a trusted Flarum domain to malicious sites via the logout route, potentially facilitating phishing or spam campaigns.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"flarum","vendor":"flarum"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"Flarum is open source discussion platform software. Prior to version 1.8.5, the Flarum `/logout` route includes a redirect parameter that allows any third party to redirect users from a (trusted) domain of the Flarum installation to redirect to any link. For logged-in users, the logout must be confirmed. Guests are immediately redirected. This could be used by spammers to redirect to a web address using a trusted domain of a running Flarum installation. The vulnerability has been fixed and published as flarum/core v1.8.5. As a workaround, some extensions modifying the logout route can remedy this issue if their implementation is safe.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2024/CVE-2024-21641.yaml","stars":null,"title":"Flarum \u003c 1.8.5 - Open Redirect"}],"tier":"weaponised"},"has_fix":true,"headline":"Flarum's Logout Route allows open redirects","id":"CVE-2024-21641","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"open_redirect","year":"2024"},"n_packages":4,"n_references":3,"next":{"headline":"D-Tale server-side request forgery through Web uploads","id":"CVE-2024-21642"},"packages":[{"ecosystem":"Packagist","fixed":["1.8.5"],"introduced":["0"],"last_affected":[],"package":"flarum/core","purl":null,"source":"GHSA-733r-8xcp-w9mr"},{"ecosystem":"Packagist","fixed":["1.8.5"],"introduced":["0"],"last_affected":[],"package":"flarum/core","purl":"pkg:composer/flarum/core","source":"GHSA-733r-8xcp-w9mr"},{"ecosystem":"Packagist","fixed":["1.8.5"],"introduced":["0"],"last_affected":[],"package":"flarum/framework","purl":null,"source":"GHSA-733r-8xcp-w9mr"},{"ecosystem":"Packagist","fixed":["1.8.5"],"introduced":["0"],"last_affected":[],"package":"flarum/framework","purl":"pkg:composer/flarum/framework","source":"GHSA-733r-8xcp-w9mr"}],"prev":{"headline":"OOB Access in CefVideoConsumerOSR::OnFrameCaptured","id":"CVE-2024-21640"},"products":["framework"],"published":"2024-01-05","related":[{"cvss_score":10,"headline":"XSS vulnerability with translator","id":"CVE-2021-32671","kev_date_added":null,"published":"2021-06-07"},{"cvss_score":9,"headline":"Cross site scripting vulnerability with discussion titles in flarum","id":"CVE-2022-41938","kev_date_added":null,"published":"2022-11-19"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2019-13183","kev_date_added":null,"published":"2019-07-07"},{"cvss_score":7.7,"headline":"Post mentions can be used to read any post on the forum without access control","id":"CVE-2023-22487","kev_date_added":null,"published":"2023-01-11"},{"cvss_score":7.5,"headline":"Flarum mishandles invalidation of user email tokens","id":"CVE-2019-11514","kev_date_added":null,"published":"2019-04-25"},{"cvss_score":7.1,"headline":"Server-Side Request Forgery via Avatar upload in flarum","id":"CVE-2023-40033","kev_date_added":null,"published":"2023-08-16"},{"cvss_score":6.8,"headline":"Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite","id":"CVE-2025-27794","kev_date_added":null,"published":"2025-03-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-03","vendors":["flarum"]},"summary":"Attackers can redirect users from a trusted Flarum domain to malicious sites via the logout route, potentially facilitating phishing or spam campaigns.","url":"https://insights.sbomify.com/CVE-2024-21641/"}