# CVE-2024-21642: D-Tale server-side request forgery through Web uploads


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 5 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-7hfx-h3j3-rwq4, PYSEC-2026-1319

## What is CVE-2024-21642?

CVE-2024-21642 is a high-severity vulnerability in man-group dtale, published on 5 Jan 2024. 

### Official description

D-Tale is a visualizer for Pandas data structures. Users hosting versions D-Tale prior to 3.9.0 publicly can be vulnerable to server-side request forgery (SSRF), allowing attackers to access files on the server. Users should upgrade to version 3.9.0, where the `Load From the Web` input is turned off by default. The only workaround for versions earlier than 3.9.0 is to only host D-Tale to trusted users.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-21642?

3 open source packages ship an affected version, including dtale. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dtale` | PyPI | All versions | 3.9.0 |
| `dtale` | PyPI | All versions | 3.9.0 |
| `dtale` | PyPI | All versions | 3.9.0 |

Products: Man D-Tale.

## How do I fix CVE-2024-21642?

Upgrade dtale to 3.9.0 or later.

## Is CVE-2024-21642 being exploited?

There is no known exploitation of CVE-2024-21642 in the wild and no public exploit code.

## Other vulnerabilities in man-group dtale

- [CVE-2024-3408](https://insights.sbomify.com/CVE-2024-3408/): Authentication Bypass and RCE in man-group/dtale (critical 9.8)
- [CVE-2026-27194](https://insights.sbomify.com/CVE-2026-27194/): D-Tale affected by Remote Code Execution through the /save-column-filter endpoint (high 8.1)
- [CVE-2024-45595](https://insights.sbomify.com/CVE-2024-45595/): D-Tale allows Remote Code Execution through the Query input on Chart Builder (medium 6.1)
- [CVE-2023-46134](https://insights.sbomify.com/CVE-2023-46134/): D-Tale vulnerable to Remote Code Execution through the Custom Filter Input (medium 6.1)
- [CVE-2026-35052](https://insights.sbomify.com/CVE-2026-35052/): D-Tale affected by Remote Code Execution through redis/shelf storage (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21642 and fix it if it is affected.

What it is: CVE-2024-21642 is a high-severity vulnerability in man-group dtale, published on 5 Jan 2024. 
Exploitation: There is no known exploitation of CVE-2024-21642 in the wild and no public exploit code.

Affected packages and fixed versions:
- dtale (PyPI): affected all versions; fixed in 3.9.0
- dtale (PyPI): affected all versions; fixed in 3.9.0
- dtale (PyPI): affected all versions; fixed in 3.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21642/ (Markdown: https://insights.sbomify.com/CVE-2024-21642/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21642
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21642
- OSV: https://osv.dev/vulnerability/CVE-2024-21642

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21642/
Summaries are generated and may contain mistakes; the official description above is the record.
