CVE-2024-21647 HTTP Request/Response Smuggling in puma
Attackers can cause unbounded resource consumption via HTTP request smuggling in the Puma web server, leading to denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-21647?
CVE-2024-21647 is a medium-severity vulnerability in puma, published on 8 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Puma is a web server for Ruby/Rack applications built for parallelism. Prior to version 6.4.2, puma exhibited incorrect behavior when parsing chunked transfer encoding bodies in a way that allowed HTTP request smuggling. Fixed versions limits the size of chunk extensions. Without this limit, an attacker could cause unbounded resource (CPU, network bandwidth) consumption. This vulnerability has been fixed in versions 6.4.2 and 5.6.8.
Weakness: CWE-444
Which versions are affected by CVE-2024-21647?
4 open source packages ship an affected version, including puma. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
puma RubyGems | All versions | 5.6.8 |
puma RubyGems | All versions | 5.6.8 |
puma RubyGems | From 6.0.0 | 6.4.2 |
puma RubyGems | From 6.0.0 | 6.4.2 |
Products include Puma Puma.
How do I fix CVE-2024-21647?
Upgrade puma to a fixed version for your release line: 5.6.8 or 6.4.2.
Is CVE-2024-21647 being exploited?
There is no known exploitation of CVE-2024-21647 in the wild and no public exploit code.
Other vulnerabilities in puma
Sources
Also known as DEBIAN-CVE-2024-21647, GHSA-c2f4-cvqm-65w2, UBUNTU-CVE-2024-21647, USN-6597-1.