{"answers":{"affected":"4 open source packages ship an affected version, including puma. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-21647 in the wild and no public exploit code.","fix":"Upgrade puma to a fixed version for your release line: 5.6.8 or 6.4.2.","what":"CVE-2024-21647 is a medium-severity vulnerability in puma, published on 8 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-21647 and fix it if it is affected.\n\nWhat it is: CVE-2024-21647 is a medium-severity vulnerability in puma, published on 8 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-21647 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- puma (RubyGems): affected all versions; fixed in 5.6.8\n- puma (RubyGems): affected all versions; fixed in 5.6.8\n- puma (RubyGems): affected from 6.0.0; fixed in 6.4.2\n- puma (RubyGems): affected from 6.0.0; fixed in 6.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-21647/ (Markdown: https://insights.sbomify.com/CVE-2024-21647/index.md)","id":"CVE-2024-21647","markdown":"https://insights.sbomify.com/CVE-2024-21647/index.md","name":"CVE-2024-21647","record":{"aliases":["DEBIAN-CVE-2024-21647","GHSA-c2f4-cvqm-65w2","UBUNTU-CVE-2024-21647","USN-6597-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby web server","requires_auth":"none","summary":"Attackers can cause unbounded resource consumption via HTTP request smuggling in the Puma web server, leading to denial of service.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"puma","vendor":"puma"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"Puma is a web server for Ruby/Rack applications built for parallelism. Prior to version 6.4.2, puma exhibited incorrect behavior when parsing chunked transfer encoding bodies in a way that allowed HTTP request smuggling. Fixed versions limits the size of chunk extensions. Without this limit, an attacker could cause unbounded resource (CPU, network bandwidth) consumption. This vulnerability has been fixed in versions 6.4.2 and 5.6.8.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"HTTP Request/Response Smuggling in puma","id":"CVE-2024-21647","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"other","year":"2024"},"n_packages":4,"n_references":2,"next":{"headline":"XWiki has no right protection on rollback action","id":"CVE-2024-21648"},"packages":[{"ecosystem":"RubyGems","fixed":["5.6.8"],"introduced":["0"],"last_affected":[],"package":"puma","purl":null,"source":"GHSA-c2f4-cvqm-65w2"},{"ecosystem":"RubyGems","fixed":["5.6.8"],"introduced":["0"],"last_affected":[],"package":"puma","purl":"pkg:gem/puma","source":"GHSA-c2f4-cvqm-65w2"},{"ecosystem":"RubyGems","fixed":["6.4.2"],"introduced":["6.0.0"],"last_affected":[],"package":"puma","purl":null,"source":"GHSA-c2f4-cvqm-65w2"},{"ecosystem":"RubyGems","fixed":["6.4.2"],"introduced":["6.0.0"],"last_affected":[],"package":"puma","purl":"pkg:gem/puma","source":"GHSA-c2f4-cvqm-65w2"}],"prev":{"headline":"Azure IoT Platform Device SDK Remote Code Execution Vulnerability","id":"CVE-2024-21646"},"products":["puma"],"published":"2024-01-08","related":[{"cvss_score":7.3,"headline":"Inconsistent Interpretation of HTTP Requests in puma","id":"CVE-2023-40175","kev_date_added":null,"published":"2023-08-18"},{"cvss_score":6.5,"headline":"HTTP Response Splitting (Early Hints) in Puma","id":"CVE-2020-5249","kev_date_added":null,"published":"2020-03-02"},{"cvss_score":5.4,"headline":"Header normalization allows for client to clobber proxy set headers in Puma","id":"CVE-2024-45614","kev_date_added":null,"published":"2024-09-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["puma"]},"summary":"Attackers can cause unbounded resource consumption via HTTP request smuggling in the Puma web server, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2024-21647/"}