# CVE-2024-21647: HTTP Request/Response Smuggling in puma

> Attackers can cause unbounded resource consumption via HTTP request smuggling in the Puma web server, leading to denial of service.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2024
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2024-21647, GHSA-c2f4-cvqm-65w2, UBUNTU-CVE-2024-21647, USN-6597-1

## What is CVE-2024-21647?

CVE-2024-21647 is a medium-severity vulnerability in puma, published on 8 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Puma is a web server for Ruby/Rack applications built for parallelism. Prior to version 6.4.2, puma exhibited incorrect behavior when parsing chunked transfer encoding bodies in a way that allowed HTTP request smuggling. Fixed versions limits the size of chunk extensions. Without this limit, an attacker could cause unbounded resource (CPU, network bandwidth) consumption. This vulnerability has been fixed in versions 6.4.2 and 5.6.8.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2024-21647?

4 open source packages ship an affected version, including puma. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `puma` | RubyGems | All versions | 5.6.8 |
| `puma` | RubyGems | All versions | 5.6.8 |
| `puma` | RubyGems | From 6.0.0 | 6.4.2 |
| `puma` | RubyGems | From 6.0.0 | 6.4.2 |

Products: Puma Puma.

## How do I fix CVE-2024-21647?

Upgrade puma to a fixed version for your release line: 5.6.8 or 6.4.2.

## Is CVE-2024-21647 being exploited?

There is no known exploitation of CVE-2024-21647 in the wild and no public exploit code.

## Other vulnerabilities in puma

- [CVE-2023-40175](https://insights.sbomify.com/CVE-2023-40175/): Inconsistent Interpretation of HTTP Requests in puma (high 7.3)
- [CVE-2020-5249](https://insights.sbomify.com/CVE-2020-5249/): HTTP Response Splitting (Early Hints) in Puma (medium 6.5)
- [CVE-2024-45614](https://insights.sbomify.com/CVE-2024-45614/): Header normalization allows for client to clobber proxy set headers in Puma (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21647 and fix it if it is affected.

What it is: CVE-2024-21647 is a medium-severity vulnerability in puma, published on 8 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-21647 in the wild and no public exploit code.

Affected packages and fixed versions:
- puma (RubyGems): affected all versions; fixed in 5.6.8
- puma (RubyGems): affected all versions; fixed in 5.6.8
- puma (RubyGems): affected from 6.0.0; fixed in 6.4.2
- puma (RubyGems): affected from 6.0.0; fixed in 6.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21647/ (Markdown: https://insights.sbomify.com/CVE-2024-21647/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21647
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21647
- OSV: https://osv.dev/vulnerability/CVE-2024-21647

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21647/
Summaries are generated and may contain mistakes; the official description above is the record.
