{"answers":{"affected":"3 open source packages ship an affected version, including vantage6. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-21649 in the wild and no public exploit code.","fix":"Upgrade vantage6 to 4.2.0 or later.","what":"CVE-2024-21649 is a high-severity code injection vulnerability in vantage6, published on 30 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-21649 and fix it if it is affected.\n\nWhat it is: CVE-2024-21649 is a high-severity code injection vulnerability in vantage6, published on 30 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-21649 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vantage6 (PyPI): affected all versions; fixed in 4.2.0\n- vantage6 (PyPI): affected all versions; fixed in 4.2.0\n- vantage6 (PyPI): affected all versions; fixed in 4.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-21649/ (Markdown: https://insights.sbomify.com/CVE-2024-21649/index.md)","id":"CVE-2024-21649","markdown":"https://insights.sbomify.com/CVE-2024-21649/index.md","name":"CVE-2024-21649","record":{"aliases":["GHSA-w9h2-px87-74vx","PYSEC-2024-30"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"vantage6 server","requires_auth":"low_privilege","summary":"Authenticated users can inject code into algorithm environment variables, leading to remote code execution on the vantage6 server.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vantage6","vendor":"vantage6"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"The vantage6 technology enables to manage and deploy privacy enhancing technologies like Federated Learning (FL) and Multi-Party Computation (MPC). Prior to 4.2.0, authenticated users could inject code into algorithm environment variables, resulting in remote code execution.  This vulnerability is patched in 4.2.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Remote code execution","id":"CVE-2024-21649","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"XWiki Remote Code Execution vulnerability via user registration","id":"CVE-2024-21650"},"packages":[{"ecosystem":"PyPI","fixed":["4.2.0"],"introduced":["0"],"last_affected":[],"package":"vantage6","purl":null,"source":"GHSA-w9h2-px87-74vx"},{"ecosystem":"PyPI","fixed":["4.2.0"],"introduced":["0"],"last_affected":[],"package":"vantage6","purl":"pkg:pypi/vantage6","source":"GHSA-w9h2-px87-74vx"},{"ecosystem":"PyPI","fixed":["4.2.0"],"introduced":["0"],"last_affected":[],"package":"vantage6","purl":"pkg:pypi/vantage6","source":"PYSEC-2024-30"}],"prev":{"headline":"XWiki has no right protection on rollback action","id":"CVE-2024-21648"},"products":["vantage6"],"published":"2024-01-30","related":[{"cvss_score":8.8,"headline":"Refresh tokens do not expire in Vantage6","id":"CVE-2023-23929","kev_date_added":null,"published":"2023-03-03"},{"cvss_score":7.2,"headline":"vantage6 Node accepts non-whitelisted algorithms from malicious server","id":"CVE-2023-47631","kev_date_added":null,"published":"2023-11-14"},{"cvss_score":6.5,"headline":"vantage6 insecure SSH configuration for node and server containers","id":"CVE-2024-21653","kev_date_added":null,"published":"2024-01-30"},{"cvss_score":6.3,"headline":"Improper Preservation of Permissions in vantage6","id":"CVE-2023-22738","kev_date_added":null,"published":"2023-03-01"},{"cvss_score":5.5,"headline":"vantage6's Pickle serialization is insecure","id":"CVE-2023-23930","kev_date_added":null,"published":"2023-10-11"},{"cvss_score":5.4,"headline":"Defining resource name as integer in vantage6 may give unintended access","id":"CVE-2023-28635","kev_date_added":null,"published":"2023-10-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-29","vendors":["vantage6"]},"summary":"Authenticated users can inject code into algorithm environment variables, leading to remote code execution on the vantage6 server.","url":"https://insights.sbomify.com/CVE-2024-21649/"}