# CVE-2024-21650: XWiki Remote Code Execution vulnerability via user registration

> Attackers can execute arbitrary code via malicious payloads in user registration fields if guest registration is enabled.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-rj7p-xjv7-7229

## What is CVE-2024-21650?

CVE-2024-21650 is a critical code injection vulnerability in Xwiki Xwiki, published on 8 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. XWiki is vulnerable to a remote code execution (RCE) attack through its user registration feature. This issue allows an attacker to execute arbitrary code by crafting malicious payloads in the "first name" or "last name" fields during user registration. This impacts all installations that have user registration enabled for guests. This vulnerability has been patched in XWiki 14.10.17, 15.5.3 and 15.8 RC1.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2024-21650?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-administration-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | From 15.0-rc-1 | 15.5.3 |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | From 15.0-rc-1 | 15.5.3 |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | From 15.6-rc-1 | 15.8-rc-1 |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | From 15.6-rc-1 | 15.8-rc-1 |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | From 2.2 | 14.10.17 |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | From 2.2 | 14.10.17 |

Products: Xwiki Xwiki.

## How do I fix CVE-2024-21650?

Upgrade org.xwiki.platform:xwiki-platform-administration-ui to a fixed version for your release line: 15.5.3, 15.8-rc-1 or 14.10.17.

## Is CVE-2024-21650 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21650 exists.

Public exploit code:

- XWiki < 4.10.20 - Remote code execution (nuclei): http/cves/2024/CVE-2024-21650.yaml

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21650 and fix it if it is affected.

What it is: CVE-2024-21650 is a critical code injection vulnerability in Xwiki Xwiki, published on 8 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21650 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected from 15.0-rc-1; fixed in 15.5.3
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected from 15.0-rc-1; fixed in 15.5.3
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected from 15.6-rc-1; fixed in 15.8-rc-1
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected from 15.6-rc-1; fixed in 15.8-rc-1
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected from 2.2; fixed in 14.10.17
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected from 2.2; fixed in 14.10.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21650/ (Markdown: https://insights.sbomify.com/CVE-2024-21650/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21650
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21650
- OSV: https://osv.dev/vulnerability/CVE-2024-21650

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21650/
Summaries are generated and may contain mistakes; the official description above is the record.
