# CVE-2024-21651: XWiki Denial of Service attack through attachments

> An attacker can cause a denial of service via CPU exhaustion by uploading a malformed TAR file to XWiki.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2024
- **Updated:** 3 Jun 2025
- **Also known as:** GHSA-8959-rfxh-r4j4

## What is CVE-2024-21651?

CVE-2024-21651 is a high-severity denial of service vulnerability in Xwiki Xwiki, published on 8 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. A user able to attach a file to a page can post a malformed TAR file by manipulating file modification times headers, which when parsed by Tika, could cause a denial of service issue via CPU consumption. This vulnerability has been patched in XWiki 14.10.18, 15.5.3 and 15.8 RC1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-21651?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-distribution-war. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-distribution-war` | Maven | From 14.10 | 14.10.18 |
| `org.xwiki.platform:xwiki-platform-distribution-war` | Maven | From 14.10 | 14.10.18 |
| `org.xwiki.platform:xwiki-platform-distribution-war` | Maven | From 15.0-rc-1 | 15.5.3 |
| `org.xwiki.platform:xwiki-platform-distribution-war` | Maven | From 15.0-rc-1 | 15.5.3 |
| `org.xwiki.platform:xwiki-platform-distribution-war` | Maven | From 15.6-rc-1 | 15.8-rc-1 |
| `org.xwiki.platform:xwiki-platform-distribution-war` | Maven | From 15.6-rc-1 | 15.8-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2024-21651?

Upgrade org.xwiki.platform:xwiki-platform-distribution-war to a fixed version for your release line: 14.10.18, 15.5.3 or 15.8-rc-1.

## Is CVE-2024-21651 being exploited?

There is no known exploitation of CVE-2024-21651 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21651 and fix it if it is affected.

What it is: CVE-2024-21651 is a high-severity denial of service vulnerability in Xwiki Xwiki, published on 8 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-21651 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-distribution-war (Maven): affected from 14.10; fixed in 14.10.18
- org.xwiki.platform:xwiki-platform-distribution-war (Maven): affected from 14.10; fixed in 14.10.18
- org.xwiki.platform:xwiki-platform-distribution-war (Maven): affected from 15.0-rc-1; fixed in 15.5.3
- org.xwiki.platform:xwiki-platform-distribution-war (Maven): affected from 15.0-rc-1; fixed in 15.5.3
- org.xwiki.platform:xwiki-platform-distribution-war (Maven): affected from 15.6-rc-1; fixed in 15.8-rc-1
- org.xwiki.platform:xwiki-platform-distribution-war (Maven): affected from 15.6-rc-1; fixed in 15.8-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21651/ (Markdown: https://insights.sbomify.com/CVE-2024-21651/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21651
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21651
- OSV: https://osv.dev/vulnerability/CVE-2024-21651

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21651/
Summaries are generated and may contain mistakes; the official description above is the record.
