# CVE-2024-21653: vantage6 insecure SSH configuration for node and server containers

> Default SSH configuration in vantage6 containers allows root login with passwords, enabling potential privilege escalation if exposed.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2024
- **Updated:** 23 Aug 2024
- **Also known as:** GHSA-2wgc-48g2-cj5w, PYSEC-2024-33, PYSEC-2024-34, PYSEC-2026-2003

## What is CVE-2024-21653?

CVE-2024-21653 is a medium-severity vulnerability in vantage6, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The vantage6 technology enables to manage and deploy privacy enhancing technologies like Federated Learning (FL) and Multi-Party Computation (MPC).  Nodes and servers get a ssh config by default that permits root login with password authentication. In a proper deployment, the SSH service is not exposed so there is no risk, but not all deployments are ideal. The default should therefore be less permissive.  The vulnerability can be mitigated by removing the ssh part from the docker file and rebuilding the docker image.  Version 4.2.0 patches the vulnerability.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-21653?

5 open source packages ship an affected version, including vantage6, vantage6-node and vantage6-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vantage6` | PyPI | All versions | 4.2.0 |
| `vantage6` | PyPI | All versions | 4.2.0 |
| `vantage6` | PyPI | All versions | 4.2.0 |
| `vantage6-node` | PyPI | All versions | 4.2.0 |
| `vantage6-server` | PyPI | All versions | 4.2.0 |

Products: Vantage6 Vantage6.

## How do I fix CVE-2024-21653?

Upgrade vantage6 to 4.2.0 or later.

## Is CVE-2024-21653 being exploited?

There is no known exploitation of CVE-2024-21653 in the wild and no public exploit code.

## Other vulnerabilities in vantage6

- [CVE-2024-21649](https://insights.sbomify.com/CVE-2024-21649/): Remote code execution (high 8.8)
- [CVE-2023-23929](https://insights.sbomify.com/CVE-2023-23929/): Refresh tokens do not expire in Vantage6 (high 8.8)
- [CVE-2023-47631](https://insights.sbomify.com/CVE-2023-47631/): vantage6 Node accepts non-whitelisted algorithms from malicious server (high 7.2)
- [CVE-2023-22738](https://insights.sbomify.com/CVE-2023-22738/): Improper Preservation of Permissions in vantage6 (medium 6.3)
- [CVE-2023-23930](https://insights.sbomify.com/CVE-2023-23930/): vantage6's Pickle serialization is insecure (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21653 and fix it if it is affected.

What it is: CVE-2024-21653 is a medium-severity vulnerability in vantage6, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-21653 in the wild and no public exploit code.

Affected packages and fixed versions:
- vantage6 (PyPI): affected all versions; fixed in 4.2.0
- vantage6 (PyPI): affected all versions; fixed in 4.2.0
- vantage6 (PyPI): affected all versions; fixed in 4.2.0
- vantage6-node (PyPI): affected all versions; fixed in 4.2.0
- vantage6-server (PyPI): affected all versions; fixed in 4.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21653/ (Markdown: https://insights.sbomify.com/CVE-2024-21653/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21653
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21653
- OSV: https://osv.dev/vulnerability/CVE-2024-21653

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21653/
Summaries are generated and may contain mistakes; the official description above is the record.
