CVE-2024-21655 Insufficient control of custom field value sizes

Medium 4.3 Published Updated

Attackers can exhaust disk space and bandwidth by submitting oversized custom field values, requiring administrators to patch the Discourse platform.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-21655?

CVE-2024-21655 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 12 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is a platform for community discussion. For fields that are client editable, limits on sizes are not imposed. This allows a malicious actor to cause a Discourse instance to use excessive disk space and also often excessive bandwidth. The issue is patched 3.1.4 and 3.2.0.beta4.

Weakness: CWE-770, CWE-400

Which versions are affected by CVE-2024-21655?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.1.4

Products include Discourse Discourse.

How do I fix CVE-2024-21655?

Upgrade discourse to 3.1.4 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-21655 being exploited?

There is no known exploitation of CVE-2024-21655 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2024-21655, GHSA-m5fc-94mm-38fx.

Is CVE-2024-21655 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free