# CVE-2024-21655: Insufficient control of custom field value sizes

> Attackers can exhaust disk space and bandwidth by submitting oversized custom field values, requiring administrators to patch the Discourse platform.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2024
- **Updated:** 3 Jun 2025
- **Also known as:** BIT-discourse-2024-21655, GHSA-m5fc-94mm-38fx

## What is CVE-2024-21655?

CVE-2024-21655 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 12 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is a platform for community discussion. For fields that are client editable, limits on sizes are not imposed. This allows a malicious actor to cause a Discourse instance to use excessive disk space and also often excessive bandwidth. The issue is patched 3.1.4 and 3.2.0.beta4.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-21655?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.1.4 |

Products: Discourse Discourse.

## How do I fix CVE-2024-21655?

Upgrade discourse to 3.1.4 or later.

## Is CVE-2024-21655 being exploited?

There is no known exploitation of CVE-2024-21655 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21655 and fix it if it is affected.

What it is: CVE-2024-21655 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 12 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-21655 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21655/ (Markdown: https://insights.sbomify.com/CVE-2024-21655/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21655
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21655
- OSV: https://osv.dev/vulnerability/CVE-2024-21655

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21655/
Summaries are generated and may contain mistakes; the official description above is the record.
