# CVE-2024-21661: Argo CD Denial of Service (DoS) Vulnerability Due to Unsafe Array Modification in Multi-threaded Environment

> Unauthenticated attackers can crash Argo CD by triggering a race condition in multi-threaded array manipulation, causing denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-argo-cd-2024-21661, GHSA-6v85-wr92-q4p7, GO-2024-2654

## What is CVE-2024-21661?

CVE-2024-21661 is a high-severity vulnerability in Argoproj Argo Cd, published on 18 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Argo CD is a declarative, GitOps continuous delivery tool for Kubernetes. Prior to versions 2.8.13, 2.9.9, and 2.10.4, an attacker can exploit a critical flaw in the application to initiate a Denial of Service (DoS) attack, rendering the application inoperable and affecting all users. The issue arises from unsafe manipulation of an array in a multi-threaded environment. The vulnerability is rooted in the application's code, where an array is being modified while it is being iterated over. This is a classic programming error but becomes critically unsafe when executed in a multi-threaded environment. When two threads interact with the same array simultaneously, the application crashes. This is a Denial of Service (DoS) vulnerability. Any attacker can crash the application continuously, making it impossible for legitimate users to access the service. The issue is exacerbated because it does not require authentication, widening the pool of potential attackers. Versions 2.8.13, 2.9.9, and 2.10.4 contain a patch for this issue.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2024-21661?

10 open source packages ship an affected version, including github.com/argoproj/argo-cd/v2, argo-cd and github.com/argoproj/argo-cd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/argoproj/argo-cd/v2` | Go | All versions | 2.8.13, 2.9.9, 2.10.4 |
| `github.com/argoproj/argo-cd/v2` | Go | All versions | 2.8.13 |
| `github.com/argoproj/argo-cd/v2` | Go | All versions | 2.8.13 |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.10.0 | 2.10.4 |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.10.0 | 2.10.4 |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.9.0 | 2.9.9 |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.9.0 | 2.9.9 |
| `argo-cd` | Bitnami | All versions | 2.10.4 |
| `github.com/argoproj/argo-cd` | Go | All versions to 1.8.7 | None |
| `github.com/argoproj/argo-cd` | Go | All versions to 1.8.7 | None |

Products: Argoproj Argo Cd.

## How do I fix CVE-2024-21661?

Upgrade github.com/argoproj/argo-cd/v2 to a fixed version for your release line: 2.8.13, 2.9.9 or 2.10.4.

## Is CVE-2024-21661 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21661 exists.

## Other vulnerabilities in Argoproj Argo Cd

- [CVE-2025-55190](https://insights.sbomify.com/CVE-2025-55190/): Argo CD: Project API Token Exposes Repository Credentials (critical 10.0)
- [CVE-2022-29165](https://insights.sbomify.com/CVE-2022-29165/): Argo CD will blindly trust JWT claims if anonymous access is enabled (critical 10.0)
- [CVE-2023-40029](https://insights.sbomify.com/CVE-2023-40029/): Cluster secret might leak in cluster details page in Argo CD (critical 9.9)
- [CVE-2022-24768](https://insights.sbomify.com/CVE-2022-24768/): Improper access control allows admin privilege escalation in Argo CD (critical 9.9)
- [CVE-2024-21652](https://insights.sbomify.com/CVE-2024-21652/): Argo CD vulnerable to Bypassing of Brute Force Protection via Application Crash and In-Memory Data Loss (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21661 and fix it if it is affected.

What it is: CVE-2024-21661 is a high-severity vulnerability in Argoproj Argo Cd, published on 18 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21661 exists.

Affected packages and fixed versions:
- github.com/argoproj/argo-cd/v2 (Go): affected all versions; fixed in 2.8.13, 2.9.9, 2.10.4
- github.com/argoproj/argo-cd/v2 (Go): affected all versions; fixed in 2.8.13
- github.com/argoproj/argo-cd/v2 (Go): affected all versions; fixed in 2.8.13
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.10.0; fixed in 2.10.4
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.10.0; fixed in 2.10.4
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.9.0; fixed in 2.9.9
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.9.0; fixed in 2.9.9
- argo-cd (Bitnami): affected all versions; fixed in 2.10.4
- github.com/argoproj/argo-cd (Go): affected all versions up to 1.8.7; no fix listed
- github.com/argoproj/argo-cd (Go): affected all versions up to 1.8.7; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21661/ (Markdown: https://insights.sbomify.com/CVE-2024-21661/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21661
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21661
- OSV: https://osv.dev/vulnerability/CVE-2024-21661

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21661/
Summaries are generated and may contain mistakes; the official description above is the record.
