# CVE-2024-21665: Pimcore Ecommerce Framework Bundle Improper Access Control allows unprivileged user to access back-office orders list

> Unauthenticated users can access back-office order lists due to missing access control checks in the Pimcore Ecommerce Framework Bundle.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-cx99-25hr-5jxf

## What is CVE-2024-21665?

CVE-2024-21665 is a medium-severity missing authorization vulnerability in pimcore ecommerce-framework-bundle, published on 11 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ecommerce-framework-bundle is the Pimcore Ecommerce Framework Bundle. An authenticated and unauthorized user can access the back-office orders list and be able to query over the information returned. Access control and permissions are not being enforced. This vulnerability has been patched in version 1.0.10.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-21665?

2 open source packages ship an affected version, including pimcore/ecommerce-framework-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/ecommerce-framework-bundle` | Packagist | All versions | 1.0.10 |
| `pimcore/ecommerce-framework-bundle` | Packagist | All versions | 1.0.10 |

Products: Pimcore E-Commerce Framework.

## How do I fix CVE-2024-21665?

Upgrade pimcore/ecommerce-framework-bundle to 1.0.10 or later.

## Is CVE-2024-21665 being exploited?

There is no known exploitation of CVE-2024-21665 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21665 and fix it if it is affected.

What it is: CVE-2024-21665 is a medium-severity missing authorization vulnerability in pimcore ecommerce-framework-bundle, published on 11 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-21665 in the wild and no public exploit code.

Affected packages and fixed versions:
- pimcore/ecommerce-framework-bundle (Packagist): affected all versions; fixed in 1.0.10
- pimcore/ecommerce-framework-bundle (Packagist): affected all versions; fixed in 1.0.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21665/ (Markdown: https://insights.sbomify.com/CVE-2024-21665/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21665
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21665
- OSV: https://osv.dev/vulnerability/CVE-2024-21665

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21665/
Summaries are generated and may contain mistakes; the official description above is the record.
