# CVE-2024-21667: Pimcore Customer Data Framework Improper Access Control allows unprivileged user to access GDPR extracts

> An authenticated user without proper permissions can access GDPR data extraction endpoints, exposing customer PII in the Pimcore customer data framework.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-g273-wppx-82w4

## What is CVE-2024-21667?

CVE-2024-21667 is a medium-severity missing authorization vulnerability in pimcore customer-data-framework, published on 11 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pimcore/customer-data-framework is the Customer Management Framework for management of customer data within Pimcore. An authenticated and unauthorized user can access the GDPR data extraction feature and query over the information returned, leading to customer data exposure. Permissions are not enforced when reaching the `/admin/customermanagementframework/gdpr-data/search-data-objects` endpoint allowing an authenticated user without the permissions to access the endpoint and query the data available there. An unauthorized user can access PII data from customers. This vulnerability has been patched in version 4.0.6.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-21667?

2 open source packages ship an affected version, including pimcore/customer-management-framework-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/customer-management-framework-bundle` | Packagist | All versions | 4.0.6 |
| `pimcore/customer-management-framework-bundle` | Packagist | All versions | 4.0.6 |

Products: Pimcore Customer Management Framework.

## How do I fix CVE-2024-21667?

Upgrade pimcore/customer-management-framework-bundle to 4.0.6 or later.

## Is CVE-2024-21667 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21667 exists.

## Other vulnerabilities in pimcore customer-data-framework

- [CVE-2023-2881](https://insights.sbomify.com/CVE-2023-2881/): Storing Passwords in a Recoverable Format in pimcore/customer-data-framework (medium 6.7)
- [CVE-2024-21666](https://insights.sbomify.com/CVE-2024-21666/): Pimcore Customer Data Framework Improper Access Control allows unprivileged user to access customers duplicates list (medium 6.5)
- [CVE-2023-4145](https://insights.sbomify.com/CVE-2023-4145/): Cross-site Scripting (XSS) - Stored in pimcore/customer-data-framework (medium 6.5)
- [CVE-2023-2756](https://insights.sbomify.com/CVE-2023-2756/): SQL Injection in pimcore/customer-data-framework (medium 6.5)
- [CVE-2021-31867](https://insights.sbomify.com/CVE-2021-31867/): Pimcore Customer Data Framework 'SegmentAssignmentController.php' Blind SQL Injection (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21667 and fix it if it is affected.

What it is: CVE-2024-21667 is a medium-severity missing authorization vulnerability in pimcore customer-data-framework, published on 11 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21667 exists.

Affected packages and fixed versions:
- pimcore/customer-management-framework-bundle (Packagist): affected all versions; fixed in 4.0.6
- pimcore/customer-management-framework-bundle (Packagist): affected all versions; fixed in 4.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21667/ (Markdown: https://insights.sbomify.com/CVE-2024-21667/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21667
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21667
- OSV: https://osv.dev/vulnerability/CVE-2024-21667

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21667/
Summaries are generated and may contain mistakes; the official description above is the record.
