# CVE-2024-21671: vantage6 username timing attack

> Attackers can enumerate valid usernames by analyzing login response times, facilitating credential attacks against the vantage6 platform.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2024
- **Updated:** 17 Oct 2024
- **Also known as:** GHSA-45gq-q4xh-cp53, PYSEC-2024-31, PYSEC-2026-2008

## What is CVE-2024-21671?

CVE-2024-21671 is a low-severity vulnerability in vantage6, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The vantage6 technology enables to manage and deploy privacy enhancing technologies like Federated Learning (FL) and Multi-Party Computation (MPC).  It is possible to find out usernames from the response time of login requests. This could aid attackers in credential attacks.  Version 4.2.0 patches this vulnerability.

Weakness: CWE-203 (Observable Discrepancy), CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2024-21671?

4 open source packages ship an affected version, including vantage6-server and vantage6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vantage6-server` | PyPI | All versions | 4.2.0 |
| `vantage6-server` | PyPI | All versions | 4.2.0 |
| `vantage6-server` | PyPI | All versions | 4.2.0 |
| `vantage6` | PyPI | All versions | 4.2.0 |

Products: Vantage6 Vantage6.

## How do I fix CVE-2024-21671?

Upgrade vantage6-server to 4.2.0 or later.

## Is CVE-2024-21671 being exploited?

There is no known exploitation of CVE-2024-21671 in the wild and no public exploit code.

## Other vulnerabilities in vantage6

- [CVE-2024-21649](https://insights.sbomify.com/CVE-2024-21649/): Remote code execution (high 8.8)
- [CVE-2023-23929](https://insights.sbomify.com/CVE-2023-23929/): Refresh tokens do not expire in Vantage6 (high 8.8)
- [CVE-2023-47631](https://insights.sbomify.com/CVE-2023-47631/): vantage6 Node accepts non-whitelisted algorithms from malicious server (high 7.2)
- [CVE-2024-21653](https://insights.sbomify.com/CVE-2024-21653/): vantage6 insecure SSH configuration for node and server containers (medium 6.5)
- [CVE-2023-22738](https://insights.sbomify.com/CVE-2023-22738/): Improper Preservation of Permissions in vantage6 (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21671 and fix it if it is affected.

What it is: CVE-2024-21671 is a low-severity vulnerability in vantage6, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-21671 in the wild and no public exploit code.

Affected packages and fixed versions:
- vantage6-server (PyPI): affected all versions; fixed in 4.2.0
- vantage6-server (PyPI): affected all versions; fixed in 4.2.0
- vantage6-server (PyPI): affected all versions; fixed in 4.2.0
- vantage6 (PyPI): affected all versions; fixed in 4.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21671/ (Markdown: https://insights.sbomify.com/CVE-2024-21671/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21671
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21671
- OSV: https://osv.dev/vulnerability/CVE-2024-21671

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21671/
Summaries are generated and may contain mistakes; the official description above is the record.
