# CVE-2024-2171: Stored XSS in zenml-io/zenml

> Attackers can inject malicious scripts via the logo_url field to compromise other users' accounts in the ZenML platform.

- **Severity:** Low 3.4 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Jun 2024
- **Updated:** 9 Aug 2024
- **Also known as:** GHSA-vwgf-7f9h-h499, PYSEC-2024-170

## What is CVE-2024-2171?

CVE-2024-2171 is a low-severity cross-site scripting vulnerability in zenml-io/zenml, published on 6 Jun 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A stored Cross-Site Scripting (XSS) vulnerability was identified in the zenml-io/zenml repository, specifically within the 'logo_url' field. By injecting malicious payloads into this field, an attacker could send harmful messages to other users, potentially compromising their accounts. The vulnerability affects version 0.55.3 and was fixed in version 0.56.2. The impact of exploiting this vulnerability could lead to user account compromise.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-2171?

3 open source packages ship an affected version, including zenml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zenml` | PyPI | All versions | 0.56.2 |
| `zenml` | PyPI | All versions | 0.56.2 |
| `zenml` | PyPI | All versions | 0.56.2 |

Products: Zenml Zenml.

## How do I fix CVE-2024-2171?

Upgrade zenml to 0.56.2 or later.

## Is CVE-2024-2171 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2171 exists.

## Other vulnerabilities in zenml-io/zenml

- [CVE-2024-2083](https://insights.sbomify.com/CVE-2024-2083/): Directory Traversal in zenml-io/zenml (critical 9.9)
- [CVE-2024-28424](https://insights.sbomify.com/CVE-2024-28424/): Code injection in n/a (high 8.8)
- [CVE-2024-25723](https://insights.sbomify.com/CVE-2024-25723/): ZenML Server Remote Privilege Escalation Vulnerability (high 8.8)
- [CVE-2024-9340](https://insights.sbomify.com/CVE-2024-9340/): Denial of Service (DoS) via Multipart Boundary in zenml-io/zenml (high 7.5)
- [CVE-2024-2035](https://insights.sbomify.com/CVE-2024-2035/): Improper Authorization in zenml-io/zenml (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-2171 and fix it if it is affected.

What it is: CVE-2024-2171 is a low-severity cross-site scripting vulnerability in zenml-io/zenml, published on 6 Jun 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2171 exists.

Affected packages and fixed versions:
- zenml (PyPI): affected all versions; fixed in 0.56.2
- zenml (PyPI): affected all versions; fixed in 0.56.2
- zenml (PyPI): affected all versions; fixed in 0.56.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-2171/ (Markdown: https://insights.sbomify.com/CVE-2024-2171/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-2171
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-2171
- OSV: https://osv.dev/vulnerability/CVE-2024-2171

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-2171/
Summaries are generated and may contain mistakes; the official description above is the record.
