# CVE-2024-21726: [20240205] - Core - Inadequate content filtering within the filter code

> Attackers can execute arbitrary scripts in user browsers due to inadequate content filtering in Joomla CMS core components.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2024
- **Updated:** 25 Dec 2024
- **Also known as:** BIT-joomla-2024-21726, GHSA-r9wf-7v4g-f656

## What is CVE-2024-21726?

CVE-2024-21726 is a medium-severity cross-site scripting vulnerability in Joomla Joomla\!, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Inadequate content filtering leads to XSS vulnerabilities in various components.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-21726?

1 open source package ship an affected version, including joomla. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joomla` | Bitnami | From 3.7.0 | 5.1.0 |

Products: Joomla Joomla\!.

## How do I fix CVE-2024-21726?

Upgrade joomla to 5.1.0 or later.

## Is CVE-2024-21726 being exploited?

There is no known exploitation of CVE-2024-21726 in the wild and no public exploit code.

## Other vulnerabilities in Joomla Joomla\!

- [CVE-2016-10033](https://insights.sbomify.com/CVE-2016-10033/): PHPMailer Command Injection (critical 9.8, exploited in the wild)
- [CVE-2023-23752](https://insights.sbomify.com/CVE-2023-23752/): Joomla! Improper Access Control (medium 5.3, exploited in the wild)
- [CVE-2026-48902](https://insights.sbomify.com/CVE-2026-48902/): Joomla! Core - [20260518] - Transport encryption downgrade for password and username reset links (critical 9.8)
- [CVE-2025-25226](https://insights.sbomify.com/CVE-2025-25226/): [20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package (critical 9.8)
- [CVE-2022-23795](https://insights.sbomify.com/CVE-2022-23795/): [20220303] - Core - User row are not bound to a authentication mechanism (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21726 and fix it if it is affected.

What it is: CVE-2024-21726 is a medium-severity cross-site scripting vulnerability in Joomla Joomla\!, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-21726 in the wild and no public exploit code.

Affected packages and fixed versions:
- joomla (Bitnami): affected from 3.7.0; fixed in 5.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21726/ (Markdown: https://insights.sbomify.com/CVE-2024-21726/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21726
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21726
- OSV: https://osv.dev/vulnerability/CVE-2024-21726

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21726/
Summaries are generated and may contain mistakes; the official description above is the record.
