CVE-2024-21733 Apache Tomcat: Leaking of unrelated request bodies in default error page
An attacker can view unrelated request bodies in default error pages, potentially exposing sensitive data from other users.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-21733?
CVE-2024-21733 is a medium-severity vulnerability in Apache Tomcat, published on 19 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat.This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43. Other, EOL versions may also be affected.
Users are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.
Weakness: CWE-209
Which versions are affected by CVE-2024-21733?
11 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat.experimental:tomcat-embed-programmatic. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.7 | 8.5.64 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.7 | 8.5.64 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0-M11 | 9.0.44 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0-M11 | 9.0.44 |
tomcat Bitnami | From 8.5.7 | 8.5.98, 9.0.45 |
org.apache.tomcat.experimental:tomcat-embed-programmatic Maven | From 9.0.43 | 9.0.44 |
5 more packages
org.apache.tomcat.experimental:tomcat-embed-programmatic Maven | From 9.0.43 | 9.0.44 |
org.apache.tomcat:tomcat-coyote Maven | From 8.5.7 | 8.5.64 |
org.apache.tomcat:tomcat-coyote Maven | From 8.5.7 | 8.5.64 |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.0-M11 | 9.0.44 |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.0-M11 | 9.0.44 |
Linux distribution packages (2)
tomcat SUSE:Linux Enterprise Server 12 SP5 | All versions | 9.0.36-3.121.1 |
tomcat SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 9.0.36-3.121.1 |
Products include Apache Tomcat.
How do I fix CVE-2024-21733?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 8.5.64 or 9.0.44.
Is CVE-2024-21733 being exploited?
There is no known exploitation of CVE-2024-21733 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2024-21733, DEBIAN-CVE-2024-21733, GHSA-f4qf-m5gf-8jm8, OESA-2024-1107, SUSE-SU-2024:0829-1, UBUNTU-CVE-2024-21733.