# CVE-2024-21733: Apache Tomcat: Leaking of unrelated request bodies in default error page

> An attacker can view unrelated request bodies in default error pages, potentially exposing sensitive data from other users.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2024
- **Updated:** 3 Nov 2025
- **Also known as:** BIT-tomcat-2024-21733, DEBIAN-CVE-2024-21733, GHSA-f4qf-m5gf-8jm8, OESA-2024-1107, SUSE-SU-2024:0829-1, UBUNTU-CVE-2024-21733

## What is CVE-2024-21733?

CVE-2024-21733 is a medium-severity vulnerability in Apache Tomcat, published on 19 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat.This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43. Other, EOL versions may also be affected.

Users are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2024-21733?

11 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat.experimental:tomcat-embed-programmatic. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.7 | 8.5.64 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.7 | 8.5.64 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.0-M11 | 9.0.44 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.0-M11 | 9.0.44 |
| `tomcat` | Bitnami | From 8.5.7 | 8.5.98, 9.0.45 |
| `org.apache.tomcat.experimental:tomcat-embed-programmatic` | Maven | From 9.0.43 | 9.0.44 |
| `org.apache.tomcat.experimental:tomcat-embed-programmatic` | Maven | From 9.0.43 | 9.0.44 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 8.5.7 | 8.5.64 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 8.5.7 | 8.5.64 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 9.0.0-M11 | 9.0.44 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 9.0.0-M11 | 9.0.44 |
| `tomcat` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 9.0.36-3.121.1 |
| `tomcat` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 9.0.36-3.121.1 |

Products: Apache Tomcat.

## How do I fix CVE-2024-21733?

Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 8.5.64 or 9.0.44.

## Is CVE-2024-21733 being exploited?

There is no known exploitation of CVE-2024-21733 in the wild and no public exploit code.

Public exploit code:

- 一个验证对CVE-2024-21733 (github_poc): https://github.com/LtmThink/CVE-2024-21733

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21733 and fix it if it is affected.

What it is: CVE-2024-21733 is a medium-severity vulnerability in Apache Tomcat, published on 19 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-21733 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.7; fixed in 8.5.64
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.7; fixed in 8.5.64
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.0-M11; fixed in 9.0.44
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.0-M11; fixed in 9.0.44
- tomcat (Bitnami): affected from 8.5.7; fixed in 8.5.98, 9.0.45
- org.apache.tomcat.experimental:tomcat-embed-programmatic (Maven): affected from 9.0.43; fixed in 9.0.44
- org.apache.tomcat.experimental:tomcat-embed-programmatic (Maven): affected from 9.0.43; fixed in 9.0.44
- org.apache.tomcat:tomcat-coyote (Maven): affected from 8.5.7; fixed in 8.5.64
- org.apache.tomcat:tomcat-coyote (Maven): affected from 8.5.7; fixed in 8.5.64
- org.apache.tomcat:tomcat-coyote (Maven): affected from 9.0.0-M11; fixed in 9.0.44
- org.apache.tomcat:tomcat-coyote (Maven): affected from 9.0.0-M11; fixed in 9.0.44

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21733/ (Markdown: https://insights.sbomify.com/CVE-2024-21733/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21733
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21733
- OSV: https://osv.dev/vulnerability/CVE-2024-21733

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21733/
Summaries are generated and may contain mistakes; the official description above is the record.
