CVE-2024-2177 Improper Restriction of Rendered UI Layers or Frames in GitLab
An attacker can abuse the OAuth authentication flow via a crafted payload to potentially take over user accounts in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-2177?
CVE-2024-2177 is a medium-severity vulnerability in Gitlab Gitlab, published on 9 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A Cross Window Forgery vulnerability exists within GitLab CE/EE affecting all versions from 16.3 prior to 16.11.5, 17.0 prior to 17.0.3, and 17.1 prior to 17.1.1. This condition allows for an attacker to abuse the OAuth authentication flow via a crafted payload.
Weakness: CWE-1021
Which versions are affected by CVE-2024-2177?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.3.0 | 16.11.5, 17.0.3, 17.1.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-2177?
Upgrade gitlab to a fixed version for your release line: 16.11.5, 17.0.3 or 17.1.1.
Is CVE-2024-2177 being exploited?
There is no known exploitation of CVE-2024-2177 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-2177, GHSA-rgx6-gx96-7frc, UBUNTU-CVE-2024-2177.