# CVE-2024-21907: Improper Handling of Exceptional Conditions in Newtonsoft.Json

> Remote attackers can cause a denial of service via stack overflow in Newtonsoft.Json by sending crafted data to the deserialization method.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jan 2024
- **Updated:** 14 Jul 2026
- **Also known as:** ECHO-b343-99af-a20d, GHSA-5crp-9r3c-p9vr, UBUNTU-CVE-2024-21907

## What is CVE-2024-21907?

CVE-2024-21907 is a high-severity denial of service vulnerability in newtonsoft:json.net, published on 3 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Newtonsoft.Json before version 13.0.1 is affected by a mishandling of exceptional conditions vulnerability. Crafted data that is passed to the JsonConvert.DeserializeObject method may trigger a StackOverflow exception resulting in denial of service. Depending on the usage of the library, an unauthenticated and remote attacker may be able to cause the denial of service condition.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2024-21907?

2 open source packages ship an affected version, including Newtonsoft.Json. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Newtonsoft.Json` | NuGet | All versions | 13.0.1 |
| `Newtonsoft.Json` | NuGet | All versions | 13.0.1 |

Products: Newtonsoft Json.net.

## How do I fix CVE-2024-21907?

Upgrade Newtonsoft.Json to 13.0.1 or later.

## Is CVE-2024-21907 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21907 exists.

Public exploit code:

- .NET 7 fork of seal-security-nuget-demo: same CVE-2024-21907 exploit story, retargeted for customers locked to .NET SDK 7. (github_poc): https://github.com/iSecurityTW/seal-security-nuget-demo-net7

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21907 and fix it if it is affected.

What it is: CVE-2024-21907 is a high-severity denial of service vulnerability in newtonsoft:json.net, published on 3 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21907 exists.

Affected packages and fixed versions:
- Newtonsoft.Json (NuGet): affected all versions; fixed in 13.0.1
- Newtonsoft.Json (NuGet): affected all versions; fixed in 13.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21907/ (Markdown: https://insights.sbomify.com/CVE-2024-21907/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21907
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21907
- OSV: https://osv.dev/vulnerability/CVE-2024-21907

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21907/
Summaries are generated and may contain mistakes; the official description above is the record.
