CVE-2024-21909 Denial of service in CBOR library
An attacker can cause a denial of service in applications using the PeterO.Cbor library by providing crafted data to decoding functions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-21909?
CVE-2024-21909 is a high-severity denial of service vulnerability in peteroupc:cbor, published on 3 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
PeterO.Cbor versions 4.0.0 through 4.5.0 are vulnerable to a denial of service vulnerability. An attacker may trigger the denial of service condition by providing crafted data to the DecodeFromBytes or other decoding mechanisms in PeterO.Cbor. Depending on the usage of the library, an unauthenticated and remote attacker may be able to cause the denial of service condition.
Weakness: CWE-407
Which versions are affected by CVE-2024-21909?
2 open source packages ship an affected version, including PeterO.Cbor. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
PeterO.Cbor NuGet | From 4.0.0 | 4.5.1 |
PeterO.Cbor NuGet | From 4.0.0 | 4.5.1 |
Products include Peteroupc Cbor.
How do I fix CVE-2024-21909?
Upgrade PeterO.Cbor to 4.5.1 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-21909 being exploited?
There is no known exploitation of CVE-2024-21909 in the wild and no public exploit code.
Other vulnerabilities in peteroupc:cbor
Sources
Also known as GHSA-6r92-cgxc-r5fg.