{"answers":{"affected":"2 open source packages ship an affected version, including PeterO.Cbor. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-21909 in the wild and no public exploit code.","fix":"Upgrade PeterO.Cbor to 4.5.1 or later.","what":"CVE-2024-21909 is a high-severity denial of service vulnerability in peteroupc:cbor, published on 3 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-21909 and fix it if it is affected.\n\nWhat it is: CVE-2024-21909 is a high-severity denial of service vulnerability in peteroupc:cbor, published on 3 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-21909 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- PeterO.Cbor (NuGet): affected from 4.0.0; fixed in 4.5.1\n- PeterO.Cbor (NuGet): affected from 4.0.0; fixed in 4.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-21909/ (Markdown: https://insights.sbomify.com/CVE-2024-21909/index.md)","id":"CVE-2024-21909","markdown":"https://insights.sbomify.com/CVE-2024-21909/index.md","name":"CVE-2024-21909","record":{"aliases":["GHSA-6r92-cgxc-r5fg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"CBOR library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using the PeterO.Cbor library by providing crafted data to decoding functions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"cbor","vendor":"peteroupc"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-407","name":"Inefficient Algorithmic Complexity"}],"description":"PeterO.Cbor versions 4.0.0 through 4.5.0 are vulnerable to a denial of \nservice vulnerability. An attacker may trigger the denial of service \ncondition by providing crafted data to the DecodeFromBytes or other \ndecoding mechanisms in PeterO.Cbor. Depending on the usage of the \nlibrary, an unauthenticated and remote attacker may be able to cause the\n denial of service condition.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in CBOR library","id":"CVE-2024-21909","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":5,"next":{"headline":"Cross-site scripting vulnerability in TinyMCE plugins","id":"CVE-2024-21910"},"packages":[{"ecosystem":"NuGet","fixed":["4.5.1"],"introduced":["4.0.0"],"last_affected":[],"package":"PeterO.Cbor","purl":null,"source":"GHSA-6r92-cgxc-r5fg"},{"ecosystem":"NuGet","fixed":["4.5.1"],"introduced":["4.0.0"],"last_affected":[],"package":"PeterO.Cbor","purl":"pkg:nuget/PeterO.Cbor","source":"GHSA-6r92-cgxc-r5fg"}],"prev":{"headline":"Cross-site scripting vulnerability in TinyMCE","id":"CVE-2024-21908"},"products":["peteroupc:cbor"],"published":"2024-01-03","related":[{"cvss_score":7.5,"headline":"upokecenter CBOR Denial of Service","id":"CVE-2024-23684","kev_date_added":null,"published":"2024-01-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-14","vendors":["peteroupc"]},"summary":"An attacker can cause a denial of service in applications using the PeterO.Cbor library by providing crafted data to decoding functions.","url":"https://insights.sbomify.com/CVE-2024-21909/"}