{"answers":{"affected":"9 open source packages ship an affected version, including django-tinymce, TinyMCE and tinymce/tinymce. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-21910 in the wild and no public exploit code.","fix":"Upgrade django-tinymce to 3.4.0 or later.","what":"CVE-2024-21910 is a medium-severity cross-site scripting vulnerability in tiny:tinymce, published on 3 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-21910 and fix it if it is affected.\n\nWhat it is: CVE-2024-21910 is a medium-severity cross-site scripting vulnerability in tiny:tinymce, published on 3 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-21910 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- django-tinymce (PyPI): affected all versions; fixed in 3.4.0\n- django-tinymce (PyPI): affected all versions; fixed in 3.4.0\n- django-tinymce (PyPI): affected all versions; fixed in 3.4.0\n- TinyMCE (NuGet): affected all versions; fixed in 5.10.0\n- TinyMCE (NuGet): affected all versions; fixed in 5.10.0\n- tinymce/tinymce (Packagist): affected all versions; fixed in 5.10.0\n- tinymce/tinymce (Packagist): affected all versions; fixed in 5.10.0\n- tinymce (npm): affected all versions; fixed in 5.10.0\n- tinymce (npm): affected all versions; fixed in 5.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-21910/ (Markdown: https://insights.sbomify.com/CVE-2024-21910/index.md)","id":"CVE-2024-21910","markdown":"https://insights.sbomify.com/CVE-2024-21910/index.md","name":"CVE-2024-21910","record":{"aliases":["GHSA-r8hm-w5f7-wj39","PYSEC-2026-632","UBUNTU-CVE-2024-21910"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"TinyMCE rich text editor","requires_auth":"none","summary":"Remote attackers can inject malicious JavaScript into TinyMCE editors via crafted URLs, allowing arbitrary code execution in users' browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"tinymce","vendor":"tiny"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"TinyMCE versions before 5.10.0 are affected by a cross-site scripting vulnerability. A remote and unauthenticated attacker could introduce crafted image or link URLs that would result in the execution of arbitrary JavaScript in an editing user's browser.","ecosystems":["NuGet","Packagist","PyPI","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting vulnerability in TinyMCE plugins","id":"CVE-2024-21910","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":9,"n_references":6,"next":{"headline":"Cross-site scripting vulnerability in TinyMCE","id":"CVE-2024-21911"},"packages":[{"ecosystem":"NuGet","fixed":["5.10.0"],"introduced":["0"],"last_affected":[],"package":"TinyMCE","purl":null,"source":"GHSA-r8hm-w5f7-wj39"},{"ecosystem":"NuGet","fixed":["5.10.0"],"introduced":["0"],"last_affected":[],"package":"TinyMCE","purl":"pkg:nuget/TinyMCE","source":"GHSA-r8hm-w5f7-wj39"},{"ecosystem":"Packagist","fixed":["5.10.0"],"introduced":["0"],"last_affected":[],"package":"tinymce/tinymce","purl":null,"source":"GHSA-r8hm-w5f7-wj39"},{"ecosystem":"Packagist","fixed":["5.10.0"],"introduced":["0"],"last_affected":[],"package":"tinymce/tinymce","purl":"pkg:composer/tinymce/tinymce","source":"GHSA-r8hm-w5f7-wj39"},{"ecosystem":"PyPI","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"django-tinymce","purl":null,"source":"GHSA-r8hm-w5f7-wj39"},{"ecosystem":"PyPI","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"django-tinymce","purl":"pkg:pypi/django-tinymce","source":"GHSA-r8hm-w5f7-wj39"},{"ecosystem":"PyPI","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"django-tinymce","purl":"pkg:pypi/django-tinymce","source":"PYSEC-2026-632"},{"ecosystem":"npm","fixed":["5.10.0"],"introduced":["0"],"last_affected":[],"package":"tinymce","purl":null,"source":"GHSA-r8hm-w5f7-wj39"},{"ecosystem":"npm","fixed":["5.10.0"],"introduced":["0"],"last_affected":[],"package":"tinymce","purl":"pkg:npm/tinymce","source":"GHSA-r8hm-w5f7-wj39"}],"prev":{"headline":"Denial of service in CBOR library","id":"CVE-2024-21909"},"products":["tiny:tinymce"],"published":"2024-01-03","related":[{"cvss_score":8.7,"headline":"TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes","id":"CVE-2026-47759","kev_date_added":null,"published":"2026-05-28"},{"cvss_score":8.7,"headline":"TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs","id":"CVE-2026-47760","kev_date_added":null,"published":"2026-05-28"},{"cvss_score":8.7,"headline":"TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection","id":"CVE-2026-47761","kev_date_added":null,"published":"2026-05-28"},{"cvss_score":8.7,"headline":"TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments","id":"CVE-2026-47762","kev_date_added":null,"published":"2026-05-28"},{"cvss_score":6.1,"headline":"Cross-site scripting vulnerability in TinyMCE","id":"CVE-2024-21908","kev_date_added":null,"published":"2024-01-03"},{"cvss_score":6.1,"headline":"Cross-site scripting vulnerability in TinyMCE","id":"CVE-2024-21911","kev_date_added":null,"published":"2024-01-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-14","vendors":["tiny"]},"summary":"Remote attackers can inject malicious JavaScript into TinyMCE editors via crafted URLs, allowing arbitrary code execution in users' browsers.","url":"https://insights.sbomify.com/CVE-2024-21910/"}