{"answers":{"affected":"2 open source packages ship an affected version, including audited. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-22047 in the wild and no public exploit code.","fix":"Upgrade audited to 5.3.3 or later.","what":"CVE-2024-22047 is a low-severity vulnerability in collectiveidea:audited, published on 4 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-22047 and fix it if it is affected.\n\nWhat it is: CVE-2024-22047 is a low-severity vulnerability in collectiveidea:audited, published on 4 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-22047 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- audited (RubyGems): affected from 4.0.0; fixed in 5.3.3\n- audited (RubyGems): affected from 4.0.0; fixed in 5.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-22047/ (Markdown: https://insights.sbomify.com/CVE-2024-22047/index.md)","id":"CVE-2024-22047","markdown":"https://insights.sbomify.com/CVE-2024-22047/index.md","name":"CVE-2024-22047","record":{"aliases":["GHSA-hjp3-5g2q-7jww"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby audit logging library","requires_auth":"low_privilege","summary":"An authenticated user can exploit a race condition to incorrectly attribute audit log entries to another user, compromising log integrity.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"audited","vendor":"collectiveidea"}],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"}],"description":"A race condition exists in Audited 4.0.0 before 5.3.3 that can result in an authenticated user to cause audit log entries to be attributed to another user.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Audited Log Integrity Errors Due to Race Condition","id":"CVE-2024-22047","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"race_condition","year":"2024"},"n_packages":2,"n_references":6,"next":{"headline":"govuk_tech_docs XSS Vulnerability","id":"CVE-2024-22048"},"packages":[{"ecosystem":"RubyGems","fixed":["5.3.3"],"introduced":["4.0.0"],"last_affected":[],"package":"audited","purl":null,"source":"GHSA-hjp3-5g2q-7jww"},{"ecosystem":"RubyGems","fixed":["5.3.3"],"introduced":["4.0.0"],"last_affected":[],"package":"audited","purl":"pkg:gem/audited","source":"GHSA-hjp3-5g2q-7jww"}],"prev":{"headline":"Information disclosure in SINEMA Remote Connect Client","id":"CVE-2024-22045"},"products":["collectiveidea:audited"],"published":"2024-01-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-29","vendors":["collectiveidea"]},"summary":"An authenticated user can exploit a race condition to incorrectly attribute audit log entries to another user, compromising log integrity.","url":"https://insights.sbomify.com/CVE-2024-22047/"}