# CVE-2024-22047: Audited Log Integrity Errors Due to Race Condition

> An authenticated user can exploit a race condition to incorrectly attribute audit log entries to another user, compromising log integrity.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jan 2024
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-hjp3-5g2q-7jww

## What is CVE-2024-22047?

CVE-2024-22047 is a low-severity vulnerability in collectiveidea:audited, published on 4 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A race condition exists in Audited 4.0.0 before 5.3.3 that can result in an authenticated user to cause audit log entries to be attributed to another user.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2024-22047?

2 open source packages ship an affected version, including audited. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `audited` | RubyGems | From 4.0.0 | 5.3.3 |
| `audited` | RubyGems | From 4.0.0 | 5.3.3 |

Products: Collectiveidea Audited.

## How do I fix CVE-2024-22047?

Upgrade audited to 5.3.3 or later.

## Is CVE-2024-22047 being exploited?

There is no known exploitation of CVE-2024-22047 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22047 and fix it if it is affected.

What it is: CVE-2024-22047 is a low-severity vulnerability in collectiveidea:audited, published on 4 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-22047 in the wild and no public exploit code.

Affected packages and fixed versions:
- audited (RubyGems): affected from 4.0.0; fixed in 5.3.3
- audited (RubyGems): affected from 4.0.0; fixed in 5.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22047/ (Markdown: https://insights.sbomify.com/CVE-2024-22047/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22047
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22047
- OSV: https://osv.dev/vulnerability/CVE-2024-22047

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22047/
Summaries are generated and may contain mistakes; the official description above is the record.
