# CVE-2024-22048: govuk_tech_docs XSS Vulnerability

> Attackers can execute malicious JavaScript in users' browsers via crafted search results in the govuk_tech_docs Ruby library.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jan 2024
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-x2xw-hw8g-6773

## What is CVE-2024-22048?

CVE-2024-22048 is a medium-severity cross-site scripting vulnerability in gov.uk:govuk_tech_docs, published on 4 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

govuk_tech_docs versions from 2.0.2 to before 3.3.1 are vulnerable to a cross-site scripting vulnerability. Malicious JavaScript may be executed in the user's browser if a malicious search result is displayed on the search page.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-22048?

2 open source packages ship an affected version, including govuk_tech_docs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `govuk_tech_docs` | RubyGems | From 2.0.2 | 3.3.1 |
| `govuk_tech_docs` | RubyGems | From 2.0.2 | 3.3.1 |

Products: Gov.uk Govuk Tech Docs.

## How do I fix CVE-2024-22048?

Upgrade govuk_tech_docs to 3.3.1 or later.

## Is CVE-2024-22048 being exploited?

There is no known exploitation of CVE-2024-22048 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22048 and fix it if it is affected.

What it is: CVE-2024-22048 is a medium-severity cross-site scripting vulnerability in gov.uk:govuk_tech_docs, published on 4 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-22048 in the wild and no public exploit code.

Affected packages and fixed versions:
- govuk_tech_docs (RubyGems): affected from 2.0.2; fixed in 3.3.1
- govuk_tech_docs (RubyGems): affected from 2.0.2; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22048/ (Markdown: https://insights.sbomify.com/CVE-2024-22048/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22048
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22048
- OSV: https://osv.dev/vulnerability/CVE-2024-22048

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22048/
Summaries are generated and may contain mistakes; the official description above is the record.
