# CVE-2024-22049: httparty Multipart/Form-Data Request Tampering Vulnerability

> Attackers can manipulate multipart form-data filenames to write files to arbitrary locations, potentially overwriting critical data.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jan 2024
- **Updated:** 14 Jul 2026
- **Also known as:** DEBIAN-CVE-2024-22049, DLA-3716-1, DLA-3900-1, GHSA-5pq7-52mg-hr42, UBUNTU-CVE-2024-22049

## What is CVE-2024-22049?

CVE-2024-22049 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 4 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

httparty before 0.21.0 is vulnerable to an assumed-immutable web parameter vulnerability. A remote and unauthenticated attacker can provide a crafted filename parameter during multipart/form-data uploads which could result in attacker controlled filenames being written.

Weakness: CWE-472 (External Control of Assumed-Immutable Web Parameter)

## Which versions are affected by CVE-2024-22049?

2 open source packages ship an affected version, including httparty. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `httparty` | RubyGems | All versions | 0.21.0 |
| `httparty` | RubyGems | All versions | 0.21.0 |

Products: Debian Debian Linux, Fedoraproject Fedora, Jnunemaker Httparty.

## How do I fix CVE-2024-22049?

Upgrade httparty to 0.21.0 or later.

## Is CVE-2024-22049 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22049 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22049 and fix it if it is affected.

What it is: CVE-2024-22049 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 4 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22049 exists.

Affected packages and fixed versions:
- httparty (RubyGems): affected all versions; fixed in 0.21.0
- httparty (RubyGems): affected all versions; fixed in 0.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22049/ (Markdown: https://insights.sbomify.com/CVE-2024-22049/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22049
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22049
- OSV: https://osv.dev/vulnerability/CVE-2024-22049

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22049/
Summaries are generated and may contain mistakes; the official description above is the record.
