# CVE-2024-22050: Iodine Static File Server Path Traversal Vulnerability

> An unauthenticated remote attacker can read files outside the public folder in the Iodine static file server via malicious URLs.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jan 2024
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-85rf-xh54-whp3

## What is CVE-2024-22050?

CVE-2024-22050 is a high-severity path traversal vulnerability in boazsegev:iodine, published on 4 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Path traversal in the static file service in Iodine less than 0.7.33 allows an unauthenticated, remote attacker to read files outside the public folder via malicious URLs.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-22050?

2 open source packages ship an affected version, including iodine. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `iodine` | RubyGems | All versions | 0.7.34 |
| `iodine` | RubyGems | All versions | 0.7.34 |

Products: Boazsegev Iodine.

## How do I fix CVE-2024-22050?

Upgrade iodine to 0.7.34 or later.

## Is CVE-2024-22050 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22050 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22050 and fix it if it is affected.

What it is: CVE-2024-22050 is a high-severity path traversal vulnerability in boazsegev:iodine, published on 4 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22050 exists.

Affected packages and fixed versions:
- iodine (RubyGems): affected all versions; fixed in 0.7.34
- iodine (RubyGems): affected all versions; fixed in 0.7.34

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22050/ (Markdown: https://insights.sbomify.com/CVE-2024-22050/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22050
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22050
- OSV: https://osv.dev/vulnerability/CVE-2024-22050

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22050/
Summaries are generated and may contain mistakes; the official description above is the record.
