{"answers":{"affected":"2 open source packages ship an affected version, including commonmarker. It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-22051 in the wild and no public exploit code.","fix":"Upgrade commonmarker to 0.23.4 or later.","what":"CVE-2024-22051 is a critical vulnerability in github:cmark-gfm, published on 4 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-22051 and fix it if it is affected.\n\nWhat it is: CVE-2024-22051 is a critical vulnerability in github:cmark-gfm, published on 4 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-22051 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- commonmarker (RubyGems): affected all versions; fixed in 0.23.4\n- commonmarker (RubyGems): affected all versions; fixed in 0.23.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-22051/ (Markdown: https://insights.sbomify.com/CVE-2024-22051/index.md)","id":"CVE-2024-22051","markdown":"https://insights.sbomify.com/CVE-2024-22051/index.md","name":"CVE-2024-22051","record":{"aliases":["DEBIAN-CVE-2024-22051","GHSA-fmx4-26r3-wxpf","UBUNTU-CVE-2024-22051"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby Markdown parser","requires_auth":"none","summary":"Remote attackers can trigger heap memory corruption and potential code execution by parsing malicious Markdown tables with excessive columns.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"cmark-gfm","vendor":"github"},{"product":"commonmarker","vendor":"gjtorikian"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"CommonMarker versions prior to 0.23.4 are at risk of an integer overflow vulnerability. This vulnerability can result in possibly unauthenticated remote attackers to cause heap memory corruption, potentially leading to an information leak or remote code execution, via parsing tables with marker rows that contain more than UINT16_MAX columns.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CommonMarker Integer Overflow Vulnerability","id":"CVE-2024-22051","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"integer_overflow","year":"2024"},"n_packages":2,"n_references":5,"next":{"headline":"Null dereference in Connect Secure","id":"CVE-2024-22052"},"packages":[{"ecosystem":"RubyGems","fixed":["0.23.4"],"introduced":["0"],"last_affected":[],"package":"commonmarker","purl":null,"source":"GHSA-fmx4-26r3-wxpf"},{"ecosystem":"RubyGems","fixed":["0.23.4"],"introduced":["0"],"last_affected":[],"package":"commonmarker","purl":"pkg:gem/commonmarker","source":"GHSA-fmx4-26r3-wxpf"}],"prev":{"headline":"Iodine Static File Server Path Traversal Vulnerability","id":"CVE-2024-22050"},"products":["github:cmark-gfm","gjtorikian:commonmarker"],"published":"2024-01-04","related":[{"cvss_score":6.4,"headline":"Quadratic complexity bugs may lead to a denial of service","id":"CVE-2023-37463","kev_date_added":null,"published":"2023-07-13"},{"cvss_score":5.3,"headline":"Quadratic complexity may lead to a denial of service in cmark-gfm","id":"CVE-2023-24824","kev_date_added":null,"published":"2023-03-31"},{"cvss_score":5.3,"headline":"Quadratic complexity may lead to a denial of service in cmark-gfm","id":"CVE-2023-26485","kev_date_added":null,"published":"2023-03-31"},{"cvss_score":5.3,"headline":"cmark-gfm out-of-bounds read in validate_protocol","id":"CVE-2023-22485","kev_date_added":null,"published":"2023-01-24"},{"cvss_score":3.5,"headline":"cmark-gfm Quadratic complexity bug in handle_close_bracket may lead to a denial of service","id":"CVE-2023-22486","kev_date_added":null,"published":"2023-01-24"},{"cvss_score":3.5,"headline":"cmark-gfm Quadratic complexity bugs may lead to a denial of service","id":"CVE-2023-22483","kev_date_added":null,"published":"2023-01-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-14","vendors":["github","gjtorikian"]},"summary":"Remote attackers can trigger heap memory corruption and potential code execution by parsing malicious Markdown tables with excessive columns.","url":"https://insights.sbomify.com/CVE-2024-22051/"}