# CVE-2024-22051: CommonMarker Integer Overflow Vulnerability

> Remote attackers can trigger heap memory corruption and potential code execution by parsing malicious Markdown tables with excessive columns.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jan 2024
- **Updated:** 14 Jul 2026
- **Also known as:** DEBIAN-CVE-2024-22051, GHSA-fmx4-26r3-wxpf, UBUNTU-CVE-2024-22051

## What is CVE-2024-22051?

CVE-2024-22051 is a critical vulnerability in github:cmark-gfm, published on 4 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CommonMarker versions prior to 0.23.4 are at risk of an integer overflow vulnerability. This vulnerability can result in possibly unauthenticated remote attackers to cause heap memory corruption, potentially leading to an information leak or remote code execution, via parsing tables with marker rows that contain more than UINT16_MAX columns.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2024-22051?

2 open source packages ship an affected version, including commonmarker. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `commonmarker` | RubyGems | All versions | 0.23.4 |
| `commonmarker` | RubyGems | All versions | 0.23.4 |

Products: Github Cmark-Gfm, Gjtorikian Commonmarker.

## How do I fix CVE-2024-22051?

Upgrade commonmarker to 0.23.4 or later.

## Is CVE-2024-22051 being exploited?

There is no known exploitation of CVE-2024-22051 in the wild and no public exploit code.

## Other vulnerabilities in github:cmark-gfm

- [CVE-2023-37463](https://insights.sbomify.com/CVE-2023-37463/): Quadratic complexity bugs may lead to a denial of service (medium 6.4)
- [CVE-2023-24824](https://insights.sbomify.com/CVE-2023-24824/): Quadratic complexity may lead to a denial of service in cmark-gfm (medium 5.3)
- [CVE-2023-26485](https://insights.sbomify.com/CVE-2023-26485/): Quadratic complexity may lead to a denial of service in cmark-gfm (medium 5.3)
- [CVE-2023-22485](https://insights.sbomify.com/CVE-2023-22485/): cmark-gfm out-of-bounds read in validate_protocol (medium 5.3)
- [CVE-2023-22486](https://insights.sbomify.com/CVE-2023-22486/): cmark-gfm Quadratic complexity bug in handle_close_bracket may lead to a denial of service (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22051 and fix it if it is affected.

What it is: CVE-2024-22051 is a critical vulnerability in github:cmark-gfm, published on 4 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-22051 in the wild and no public exploit code.

Affected packages and fixed versions:
- commonmarker (RubyGems): affected all versions; fixed in 0.23.4
- commonmarker (RubyGems): affected all versions; fixed in 0.23.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22051/ (Markdown: https://insights.sbomify.com/CVE-2024-22051/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22051
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22051
- OSV: https://osv.dev/vulnerability/CVE-2024-22051

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22051/
Summaries are generated and may contain mistakes; the official description above is the record.
