CVE-2024-22091 Excessive resource consumption due to lack to request path size limits
Attackers can cause denial of service by sending excessively large request paths, impacting Mattermost chat platform availability.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-22091?
CVE-2024-22091 is a low-severity denial of service vulnerability in Mattermost Mattermost Server, published on 26 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 8.1.x <= 8.1.10, 9.6.x <= 9.6.0, 9.5.x <= 9.5.2 and 8.1.x <= 8.1.11 fail to limit the size of a request path that includes user inputs which allows an attacker to cause excessive resource consumption, possibly leading to a DoS via sending large request paths
Which versions are affected by CVE-2024-22091?
7 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 8.1.0 | 8.1.12 |
github.com/mattermost/mattermost-server Go | From 8.1.0 | 8.1.12 |
github.com/mattermost/mattermost-server Go | From 8.1.0+incompatible | 8.1.12+incompatible, 9.5.3+incompatible, 9.6.1+incompatible |
github.com/mattermost/mattermost-server Go | From 9.5.0 | 9.5.3 |
github.com/mattermost/mattermost-server Go | From 9.5.0 | 9.5.3 |
github.com/mattermost/mattermost-server Go | From 9.6.0-rc1 | 9.6.1 |
1 more packages
github.com/mattermost/mattermost-server Go | From 9.6.0-rc1 | 9.6.1 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2024-22091?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 8.1.12, 8.1.12+incompatible, 9.5.3+incompatible or 9.6.1+incompatible.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-22091 being exploited?
There is no known exploitation of CVE-2024-22091 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-p2wq-4ggp-45f3, GO-2024-2796.