CVE-2024-2213 Improper Authentication in zenml-io/zenml

Low 3.3 Published Updated

An attacker with an active session can change a user's password without verification, leading to unauthorized account takeover in ZenML.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2024-2213?

CVE-2024-2213 is a low-severity authentication bypass vulnerability in zenml-io/zenml, published on 6 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Due to improper authentication mechanisms, an attacker with access to an active user session can change the account password without needing to know the current password. This vulnerability allows for unauthorized account takeover by bypassing the standard password change verification process. The issue was fixed in version 0.56.3.

Weakness: CWE-620

Which versions are affected by CVE-2024-2213?

3 open source packages ship an affected version, including zenml. It affects 1 product.

PackageAffectedFixed in
zenml PyPIAll versions0.56.3
zenml PyPIAll versions0.56.3
zenml PyPIAll versions0.56.3

Products include Zenml Zenml.

How do I fix CVE-2024-2213?

Upgrade zenml to 0.56.3 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2024-2213 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2213 exists.

Sources

Also known as GHSA-j527-v579-m98h, PYSEC-2024-193.

Is CVE-2024-2213 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free