# CVE-2024-2213: Improper Authentication in zenml-io/zenml

> An attacker with an active session can change a user's password without verification, leading to unauthorized account takeover in ZenML.

- **Severity:** Low 3.3 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2024
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-j527-v579-m98h, PYSEC-2024-193

## What is CVE-2024-2213?

CVE-2024-2213 is a low-severity authentication bypass vulnerability in zenml-io/zenml, published on 6 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Due to improper authentication mechanisms, an attacker with access to an active user session can change the account password without needing to know the current password. This vulnerability allows for unauthorized account takeover by bypassing the standard password change verification process. The issue was fixed in version 0.56.3.

Weakness: CWE-620 (Unverified Password Change)

## Which versions are affected by CVE-2024-2213?

3 open source packages ship an affected version, including zenml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zenml` | PyPI | All versions | 0.56.3 |
| `zenml` | PyPI | All versions | 0.56.3 |
| `zenml` | PyPI | All versions | 0.56.3 |

Products: Zenml Zenml.

## How do I fix CVE-2024-2213?

Upgrade zenml to 0.56.3 or later.

## Is CVE-2024-2213 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2213 exists.

## Other vulnerabilities in zenml-io/zenml

- [CVE-2024-2083](https://insights.sbomify.com/CVE-2024-2083/): Directory Traversal in zenml-io/zenml (critical 9.9)
- [CVE-2024-28424](https://insights.sbomify.com/CVE-2024-28424/): Code injection in n/a (high 8.8)
- [CVE-2024-25723](https://insights.sbomify.com/CVE-2024-25723/): ZenML Server Remote Privilege Escalation Vulnerability (high 8.8)
- [CVE-2024-9340](https://insights.sbomify.com/CVE-2024-9340/): Denial of Service (DoS) via Multipart Boundary in zenml-io/zenml (high 7.5)
- [CVE-2024-2035](https://insights.sbomify.com/CVE-2024-2035/): Improper Authorization in zenml-io/zenml (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-2213 and fix it if it is affected.

What it is: CVE-2024-2213 is a low-severity authentication bypass vulnerability in zenml-io/zenml, published on 6 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2213 exists.

Affected packages and fixed versions:
- zenml (PyPI): affected all versions; fixed in 0.56.3
- zenml (PyPI): affected all versions; fixed in 0.56.3
- zenml (PyPI): affected all versions; fixed in 0.56.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-2213/ (Markdown: https://insights.sbomify.com/CVE-2024-2213/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-2213
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-2213
- OSV: https://osv.dev/vulnerability/CVE-2024-2213

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-2213/
Summaries are generated and may contain mistakes; the official description above is the record.
