CVE-2024-22188 TYPO3 Install Tool vulnerable to Code Execution
Authenticated administrators can execute arbitrary shell commands via the Install Tool, leading to code execution on the server.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-22188?
CVE-2024-22188 is a high-severity command injection vulnerability in Typo3 Typo3, published on 5 Mar 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
TYPO3 before 13.0.1 allows an authenticated admin user (with system maintainer privileges) to execute arbitrary shell commands (with the privileges of the web server) via a command injection vulnerability in form fields of the Install Tool. The fixed versions are 8.7.57 ELTS, 9.5.46 ELTS, 10.4.43 ELTS, 11.5.35 LTS, 12.4.11 LTS, and 13.0.1.
Weakness: CWE-94
Which versions are affected by CVE-2024-22188?
12 open source packages ship an affected version, including typo3/cms-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms-core Packagist | From 10.0.0 | 10.4.43 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.43 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.35 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.35 |
typo3/cms-core Packagist | From 12.0.0 | 12.4.11 |
typo3/cms-core Packagist | From 12.0.0 | 12.4.11 |
6 more packages
typo3/cms-core Packagist | From 13.0.0 | 13.0.1 |
typo3/cms-core Packagist | From 13.0.0 | 13.0.1 |
typo3/cms-core Packagist | From 8.0.0 | 8.7.57 |
typo3/cms-core Packagist | From 8.0.0 | 8.7.57 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.46 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.46 |
Products include Typo3 Typo3.
How do I fix CVE-2024-22188?
Upgrade typo3/cms-core to a fixed version for your release line: 10.4.43, 11.5.35, 12.4.11 or 13.0.1.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2024-22188 being exploited?
There is no known exploitation of CVE-2024-22188 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as GHSA-5w2h-59j3-8x5w.